Not rendering CPP comments

Aug 5, 2009 at 9:06 PM

Hi

The following method's comments in cpp does not get rendered by sandcastle . I believe this is a known issue.. Could you please let me know if there is a fix for this?

void Add(System::Collections::Generic::IEnumerable<System::Collections::Generic::Keyvaluepair<System::String^, System::String^>^>

 

Thanks & Regards,

Phalguni.

Coordinator
Aug 5, 2009 at 9:28 PM

Have you set the CppCommentsFixUp project property to True?  That fixes most C++ method signature issues related to generics.  I think there are a couple of MRefBuilder issues with regard to generic parameters types too but I'd have to go look them up.

Eric

 

Aug 7, 2009 at 4:23 PM
Hi Eric,
 
Setting the CppCommentsFixUp project property to True solved the problem .
 
Thanks ,
Phalguni.

On Wed, Aug 5, 2009 at 3:28 PM, EWoodruff <notifications@codeplex.com> wrote:

From: EWoodruff

Have you set the CppCommentsFixUp project property to True?  That fixes most C++ method signature issues related to generics.  I think there are a couple of MRefBuilder issues with regard to generic parameters types too but I'd have to go look them up.

Eric

 

Read the full discussion online.

To add a post to this discussion, reply to this email (SHFB@discussions.codeplex.com)

To start a new discussion for this project, email SHFB@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com