Sandle castle helpbuilder for .net 2.0

Topics: Developer Forum, User Forum
Jul 24, 2013 at 8:31 AM
I want a installer package for Sandle castle helpbuilder which can be installed on .net framework 2.0. The new release of SHFB(sandlecastled help builder) requires .net framework 4 as prerequisite. Can you give me link of SHFB which can be installed on 2.0 framework and which can generate documentation for visual studio 2005 dlls.
I really don't want to install .NET 4.

Thanks for helping
Jul 24, 2013 at 3:06 PM
You'll probably have to go back to v1.7.0.0 to get a version that runs on .NET 2.0 and you'll need the corresponding May 2008 release of the Sandcastle tools. They're very old and lack a lot of the newer features and fixes. I also cannot provide support for them anymore.

There's really no downside to installing .NET 4.0 and using the latest tools which include all the latest features and fixes. .NET 4.0 will run side by side with the older frameworks and SHFB and Sandcastle are capable of documenting assemblies from .NET 1.1 to .NET 4.5 without any issues.

Jul 25, 2013 at 8:05 AM
Thank you for your help. I'll install .NET 4.0 as soon as possible.