Html2 build fails but WebSite works

Topics: User Forum
Sep 1, 2008 at 6:51 AM
Hello everyone,

I'm experiencing some trouble with the build of HtmlHelp2.x with SHFP (version 1.7)

At the very end of the build log I can see the following:

Compiling HTML Help 2.x file...
Microsoft Help Compiler Version 2.07.61224.0 Copyright (c) Microsoft Corp.

Error HXC4001: File file:///C:/home/temp/Sandcastle/myproject/Output/netbasis.HxC, Line 2, Char 77: XML syntax error: No data is available for the requested resource.

Fehler beim Bearbeiten der Ressource 'MS-Help://Hx/Resources/HelpCollection.dtd'.

Fatal Error HXC2056: Failed to parse the XML file: C:\home\temp\Sandcastle\myproject\Output\myproject.HxC
    Last step completed in 00:00:00.4530

I looked for the file file:///C:/home/temp/Sandcastle/myproject/Output/netbasis.HxC but did not found it on the drive.
Building the documentation as a Web site works well but I need HtmlHelp2 to integrate my help into Visual Studio's one.

Any idea how to fix this problem ? If you need more info, please just ask.


Sep 1, 2008 at 4:33 PM
A search of Google suggests that the most common cause appears to be a corrupt Help 2 compiler install.  You can try reinstalling the Visual Studio SDK to try and fix it.  If that's too much, you can try the steps outlined here:

Sep 2, 2008 at 7:35 AM
Well I already tried to re-install the Visual Studio 2008 SDK but this didn't help.
I followed your tip and deinstalled it once more. I found the new Visual Studio 2008 SDK 1.1 and installed it.

Now compilation of HTML Help 2.x works, many thanks.
I've just "loosed" the conceptual content editor: the window can be opened but the left pane does not appear.
Sep 2, 2008 at 3:58 PM
The window settings seem to get corrupted.  See this thread for the fix:

Sep 3, 2008 at 6:37 AM
Hi Eric,

many thanks for you help, everything works fine now.
And thanks for your tool: its a great one !!!