Hierarchical table of content plug in does not work

Jun 12, 2008 at 2:21 PM
Edited Jun 12, 2008 at 2:22 PM
Hi,

I have an help file with conceptual contents followed by the namespaces.

I've got 4 assemblies each defining their own namespaces as follows:
  • GDTM.TrussPlant.Core
  • GDTM.TrussPlant.FileFormats
  • GDTM.TrussPlant.FileFormats.Converters
  • GDTM.TrussPlant.PDF
I assumed that by adding the plugin I would get something like this:
  • GDTM.TrussPlant
    • Core
    • FileFormats
      • Converters
    • PDF
Or something along those lines...

Instead I always have:
  • GDTM.TrussPlant.Core
  • GDTM.TrussPlant.FileFormats
  • GDTM.TrussPlant.FileFormats.Converters
  • GDTM.TrussPlant.PDF
I tried setting the "Create containers for common root..." option to 1 part (even tried 2) and also used the "Insert nested..." option enabled/disabled without any success.

Is there something I am missing here ?


Coordinator
Jun 12, 2008 at 4:20 PM
Edited Jun 12, 2008 at 4:24 PM

The namespaces will still be fully qualified.  There's a reason why, but I don't recall exactly.  I'm pretty sure it has to do with the fact that the TOC titles in Help 2 are generated off of the page titles so changing them would require modifying the pages.  As such, you still get fully qualified names in the TOC.  It should still nest the namespaces though.  If you have an example that isn't working and can e-mail it to me, I'll take a look at it.

Eric

Jun 16, 2008 at 1:09 PM
Hi Eric,

I sent you an example through mail, did you receive it and was it relevant ?

Thank you

Stécy

Coordinator
Jun 16, 2008 at 4:00 PM

Yes, I got it.  I took a quick look at it and was able to duplicate the problem but I haven't looked into fixing it yet.

Eric