This project has moved and is read-only. For the latest updates, please go here.

Cannot compile project - error Unknown field tag: 'ReferencePath'

Topics: Developer Forum, User Forum
Jan 11, 2012 at 5:40 PM
Edited Jan 11, 2012 at 5:53 PM


I have tried running the Sandcastle Builder on a simple project I created consisting of one DLL.  After a while from doing .NET I went back - I thought I had Sandcastle Builder installed on my machine but I didn't so just have reinstalled.  I initially downloaded and installed version, but then reran the install when I hit the following error.  Both versions give me the same error which is Error BE0020: Unknown field tag: 'ReferencePath'


The log is as follows:

[Sandcastle Help File Builder Utilities, version]
Creating output and working folders...
Clearing working folder...
Finding tools...
Found Sandcastle tools in 'C:\Program Files\Sandcastle\'
Searching for HTML Help 1 compiler...
Found HTML Help 1 compiler in 'C:\Program Files\HTML Help Workshop\'
Validating and copying documentation source information
Source: D:\My Development\ATD\ApplicationFramework\applicationframework\AppFramework\ATD.CodeTemplates\bin\Debug\ATD.CodeTemplates.dll
    Found assembly 'D:\My Development\ATD\ApplicationFramework\applicationframework\AppFramework\ATD.CodeTemplates\bin\Debug\ATD.CodeTemplates.dll'
Source: D:\My Development\ATD\ApplicationFramework\applicationframework\AppFramework\ATD.CodeTemplates\bin\Debug\ATD.CodeTemplates.xml

Copying XML comments files
    D:\My Development\ATD\ApplicationFramework\applicationframework\AppFramework\ATD.CodeTemplates\bin\Debug\ATD.CodeTemplates.XML -> D:\My Development\ATD\ApplicationFramework\applicationframework\AppFramework\Help\Help\Working\ATD.CodeTemplates.XML
Generating shared content files (en-US, English (United States))...
    Last step completed in 00:00:00.0970
Generating API filter for MRefBuilder...
    Last step completed in 00:00:00.0180
Generating reflection information...
    Last step completed in 00:00:00.0160

SHFB: Error BE0020: Unknown field tag: 'ReferencePath'

Anyone got any ideas what this is or how to fix it?

I am using VS2008 to create my project although I have the Express editions on the machine.  I have HTML Help Workshop installed which it can find.

Update:  I get the same error where I have loaded an existing project I had worked on with Sandcastle Help File Builder UI.




Jan 11, 2012 at 6:02 PM

Something must have gone wrong with the setups.  I noticed it was installed twice in the Programs and Features.  I uninstalled and reinstalled and it seems to be working fine.



Jan 11, 2012 at 8:18 PM

In case anyone else runs into this, it is noted in the "Important Information" section of the v1.9.3.3. release notes on the download page.  While it's in beta, I'm keeping the core version number (1.9.3) the same as the prior stable release so that plug-ins continue to work with both versions.  MSI installers only look at the first three digits of the version number and since they haven't changed, it will not remove any prior version with the same first three digits and you end up with two copies that conflict.  This won't be a problem once it's out of beta since the version number will change in such a way that old copies will be removed.