This project has moved and is read-only. For the latest updates, please go here.

[Missing namespace summary for N:]

Topics: User Forum
Dec 5, 2006 at 4:21 PM

I am trying to document a windows service but the builder ( generates some unwanted things to the web page

- Missing namespace summary for N: => this message shows up on the namespaces page and it comes after I set DocumentPrivates to true
- An extra "Namespace" node in the tree view with the sub node "<Module> Class"

How can I get rid of them? :) Have I forgot to put some XML tags to somewhere?



Dec 5, 2006 at 4:39 PM
Use the Namespaces button to the right of the list of assemblies to document to specify namespace comments and to mark which namespaces to include. By the way, the current production release is

Dec 5, 2006 at 4:40 PM
Also, if you don't care about the missing summaries, etc, set the matching Document* project option to false. See the help file for more details.

Dec 8, 2006 at 5:07 PM
I tried to comment the namespaces I use with the GUI tool but it didn't help. I installed the version but since the DocumentPrivates doesn't work in that version I can't see how does it work. Is the next version coming soon? :)

Dec 8, 2006 at 8:08 PM
The December CTP of Sandcastle is due out soon, probably by Sunday or early next week. That should fix the bug in MRefBuilder that prevents documenting privates. An updated version of the help file builder will follow it within a day or two.

Dec 12, 2006 at 8:27 AM
The new version solved this issue.
Big thanks!