How do you get your cool file icons to display in the Contents pane?

Jul 29, 2011 at 1:40 AM

Instead of the goofy question mark ones.

Coordinator
Jul 29, 2011 at 6:11 PM

Can you be more specific?  The content pane in what?  The help file?  What type of content/help file (Help 1, Help 2, ...)?

Eric

 

Jul 29, 2011 at 6:24 PM

Sorry, I should have been more clear. Help 1, Contents tab on the left hand side of the help file viewer.

Here is a picture with a big ugly arrow pointing at the big ugly question mark.

qmark

Coordinator
Jul 29, 2011 at 7:32 PM

I'm not sure what changed.  It used to work but I see now that I'm getting the same results.  I'll see if I can find out why it's doing that.

Eric

 

Jul 31, 2011 at 1:16 AM
Edited Jul 31, 2011 at 7:28 AM

Thanks. Much appreciated. This is not a show stopper, but it would be nice to have things look prettier. Your project has been a huge help. Going though your source code it is clear that you put a lot of time, hard work, and knowledge into it. <AliG>Respect!</AliG>.

Sorry about the sloppy report. I did put some effort into figuring this out before posting. I can't find the icon that looks like your text file in the Working/Output/HtmlHelp1/icons folder. I thought maybe there was some magic going on in the Help1x.hpp file in the incantations under the [WINDOWS] section, but I couldn't convince myself that is what is going on here.

Coordinator
Aug 2, 2011 at 7:25 PM

The icons in the working folder are for the topics.  The one in the Help 1 TOC is controlled by the Help 1 viewer.  I found that if you set the project's BinaryTOC option to false, it will use the question mark icon for the topics in the TOC.  Setting it back to true, the default, makes it use the "page" icon.  This is typically what you want anyway is it results in a more efficient help file.  I thought that's what the problem was but what confused me was that after setting it back to true in my test build, it still showed the question mark icon.  For some reason, it didn't pick up the change in the project until I closed and reopened it.  Once I did that, it displayed the expected result.

Eric

 

Aug 3, 2011 at 12:21 AM

That does the trick. Thanks! I would have never guessed that was what controlled it in a million years.

Now if I could only get the help files to not render numerals and parentheses in italic inside <math> tags, I would be in hog heaven.

Coordinator
Aug 3, 2011 at 5:12 PM

Check Presentation.css in the %ProgramFiles (x86)%\Sandcastle\Presentation\VS2005\Styles folder.  It controls most of the styling on the elements.  Most likely it's span.math as I see it applies the italic font style.  Comment the font-style line out and it should render the text without the italics.

Eric