This project has moved and is read-only. For the latest updates, please go here.

Do you have any plan for VS2010?

Topics: Developer Forum, Project Management Forum, User Forum
Aug 30, 2010 at 1:54 PM

First I think this is greate tool..
And I've one question for you..
Do you have a plan for visual studio 2010 ??
I try it with VS.2010 but it doesn't work well..

Sorry , I'm short in english ..  so i can't explane my question well..

but please answer for me...

Best regards...

Aug 30, 2010 at 5:06 PM

SHFB is a standalone tool and does not integrate into any version of Visual Studio yet.  Perhaps you are referring to DocProject?  SHFB fully supports documentation of .NET 4.0 assemblies.  If you build from the command line, then you do currently need to use MSBuild 3.5 to build the SHFB project rather than MSBuild 4.0.  I've started creating a version that will run under MSBuild 4.0 but I haven't gotten around to finishing up work on it just yet.



Sep 2, 2010 at 7:02 AM

You sure about this? I've tried many times but have not gotten a pure .NET 4.0 assembly to work with the latest SHFB (v1.9.1.0)+latest Sandcastle (v2.6.1062.1). It can never resolve the 4.0 references. Always gives an error like this:

Generating reflection information...
  MrefBuilder (v2.6.10621.1)
  Copyright c Microsoft 2006
  Info: Loaded 1 assemblies for reflection and 0 dependency assemblies.
MREFBUILDER : error : Unresolved assembly reference: System.Configuration (System.Configuration, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a) required by MyClassAssemblyProject
    Last step completed in 00:00:02.2154

I of course add a file reference to correct 4.0 files (C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\.NETFramework\v4.0 on my machine), but that doesn't seem to affect it. Also, in my VS2010 project, I will set all the references to CopyLocal=True, but even then, the dependent assemblies (like Accessibility) throw this same error. I can't seem to coerce it to use the references I've added in my project, nor in the SHFB project.

Any tricks on how to get around this? I've been patiently waiting for someone to fix this, but maybe it already is and i'm missing something?? Thanks!

Sep 2, 2010 at 8:35 PM

Yes, positive.  I think I'd of noticed something like that as would many others.  As I recall, that error typically occurs when you don't have an MRefBuilder.exe.config at all or one that doesn't contain a supportedRuntime element for the latest .NET 4.0 framework.  You might check to be sure that it is current and, if you are using Vista or Windows 7, that you don't have a virtualized copy hanging around with an invalid version number in it for one of the betas (i.e. a copy from the older Sandcastle Styles patches).  The copy of the file that comes with the latest Sandcastle release just has the two entries: one for v4.0.30319 and another for v2.0.50727.  You'll find the config file in %ProgramFiles%\Sandcastle\ProductionTools.



Sep 3, 2010 at 1:22 AM


Thanks, now I'm glad I asked!! Sure enough, my config file was missing an entry for the RTM version of 4.0. For the benefit of others, I added the "RTM" line below:

<?xml version="1.0"?>
    <supportedRuntime version="v4.0.30319"/> <!-- 4.0 RTM -->
    <supportedRuntime version="v4.0.30128"/> <!-- 4.0 RC installed by VS2010 RC -->
    <supportedRuntime version="v4.0.21006"/> <!-- 4.0 Beta 2 installed by VS2010 Beta 2 -->
    <supportedRuntime version="v4.0.20506"/> <!-- 4.0 Beta 1 installed by VS2010 Beta 1 -->
    <supportedRuntime version="v2.0.50727"/> <!-- 2.0 RTM -->

to C:\Program Files (x86)\Sandcastle\ProductionTools\MrefBuilder.exe.config - then re-launched SHFB and it worked as expected, it could then resolve the 4.0 references. Thanks again Eric!!


Sep 3, 2010 at 3:21 AM

Since that's from the Sandcastle Styles patch prior to the latest release, it could be that you've got a virtualized copy that is overriding the installed version or perhaps the latest version didn't get installed because the file had a newer date or some other reason.



Sep 3, 2010 at 5:10 AM

First.. thanks for all ..

But I still don't know about my question...

1. Can i make .chm from VS2010 files(Xml, exe, vcxproj, sln .... .. ) with "sandcastle help file builder gui( Ver. )"&"Sandcastle (Ver. 2.6.10621.1)"?

   : It makes error Like this..

    SHFB: Error BE0068: Incompatible Visual Studio project file format.  See error code help topic for more information.
   This project may be for a newer version of MSBuild and cannot be loaded.  Error message:
   The attribute "Label" in element <ItemGroup> is unrecognized.  C:\chm\Prj.vcxproj

    I don't know well but i think help file builder gui is not support Framework 4.0 now... isn't it?

 < this project made by VS2010 C++ >

 << I added >>

  - prj.exe

  - prj.vcxproj

  - prj.xml

  - prj.sln

   and many References

2. If I lost something teach me plz....


I try many things, like change option and property... but it didn't work well..

This is the first time that i use this App.. so i've too much question... :-)

Sorry to bother you... but teach me please...

 - Kim

Sep 3, 2010 at 5:50 AM


Is this managed C++? I believe that Sandcastle only works with managed languages, but I'm not sure. Also, are you familiar with SHFB and just can't get C++ working? Or are you new to the whole thing? For example, when SHFB talks about "projects", it's talking about SHFB projects, NOT VS projects. So if you create a new SHFB project, go to Document Explorer tool window, right-click on Documentation Sources, and point to your .dll and .xml file, and build - that's all you should need to get started. Hope that helps


Sep 3, 2010 at 8:25 PM

SHFB is built with references to MSBuild 3.5 assemblies so the API it uses to load project files cannot handle MSBuild 4.0 project files which contain newer attributes that MSBuild 3.5 can't handle.  So, instead of using the preferred method of adding the solution as the documentation source, you need to add the individual assemblies and XML comments files that are built by the projects as documentation sources along with any references that it can't figure out automatically.  If you haven't done so already, read through the topics and walkthroughs in the Getting Started section of the SHFB help file.  They will help you set up a project and become familiar with the common tasks.



Sep 8, 2010 at 3:17 AM

It contain MSBuild 4.0 assemblies...and i can't resolve my problem yet..

Maybe i need more study with manual and help file..

Thank's for your fast reply...

It's very useful information to me...

 Best regards..

Oct 14, 2010 at 10:42 PM

I have use Sandcaster builder many times in the past, but this is the first time ever, I can't not get it to build my silverlight 4.0 project documentation.  I have followed all of the above advice, include checking the configuration file. Nada. This is the error that I getting:

refBuilder (v2.6.10621.1)

Copyright c Microsoft 2006

Info: Loaded 2 assemblies for reflection and 0 dependency assemblies.

MREFBUILDER : error : Unresolved assembly reference: System.Windows (System.Windows, Version=, Culture=neutral, PublicKeyToken=7cec85d7bea7798e) required by System.Windows.Controls

Last step completed in 00:00:05.7056

   I really would like to show my clients this cool tool but I can't if it doesnt work.....




Oct 15, 2010 at 12:18 AM


What IS that assembly? Despite the name, "System.Windows" isn't a native .NET assembly from any version, as far as I know - neither is System.Windows.Controls. Even if they were, version is odd for the .NET framework.

Are these your custom assemblies or perhaps 3rd party assemblies from some component vendor? Assuming you know where these files are on the file system, you should be able to use SHFB and in the Project Explorer, just manually add a "Reference" to those files, whereever they exist on disk.

In other words, I don't think this is a core .NET framework issue, this looks like SHFB simply can't find your reference, and that is fixed by adding the reference to the SHFB project. Hope that helps


Oct 15, 2010 at 2:32 AM

Silverlight is most likely similar to the Compact Framework.  While Sandcastle can produce documentation for Compact Framework assemblies, you have to take some extra steps to get it to find the references correctly.  The same is probably true of Silverlight projects.  I haven't used the Compact Framework or Silverlight so I'm going on info supplied by other users.  Here's the info for the Compact Framework.  Perhaps you can use it to get the Silverlight references working:

In order to document Compact Framework applications you also need to add a reference item for the Compact Framework assemblies.  These are usually located under the Visual Studio 20xx installation folder.  The easiest way to reference them is to add a reference item with a path similar to the following:


So, for Silverlight, you'd add a reference item the same way and then modify the path to point to the Silverlight assemblies.  If somebody can send me sample Silverlight project that they can't document, I'll see if I can get it working.  My e-mail address is in the About Box in the GUI and in the footer of the pages in the help file.  If you do manage to get it working on your own, please send me the necessary info and I'll include it in the SHFB documentation for the next release.  Thanks.