This project has moved and is read-only. For the latest updates, please go here.

XML comments not appearing in CHM file

Feb 11, 2008 at 2:38 PM
Hi all,

I'm new to Sandcastle and the Help File Builder. Versions I'm using:

Sandcastle Jan 2008 release
Help File Builder (v.

I'm just trying something very simple to test things out and for some reason the XML comments are not appearing in the CHM file. From what I can tell (and have read), I'm not doing anything wrong but I may have missed something.

Here is my code:

''' <summary>
''' Gets the tombstone information for an applicant.
''' </summary>
''' <param name="FileNumber">test</param>
''' <remarks>test</remarks>
Public Sub GetApplicantTombstone(ByVal FileNumber As Integer)

End Sub

and here is the XML file that is generated:

<?xml version="1.0"?>
<member name="P:camis.clsApplicant.GivenName">
Gets or sets the given name of the applicant.
<value>Given name of the applicant.</value>
<remarks>The value must only contain characters.</remarks>
</member><member name="M:camis.clsApplicant.GetApplicantTombstone(System.Int32)">
Gets the tombstone information for an applicant.
<param name="FileNumber">test</param>

I then point SHFB to my assembly (and XML file) and then build. The CHM file appears fine with all of my classes, properties and methods, however, none of the XML comments are appearing.

I should also mention that when viewing the CHM, I'm assuming that when I select an item from the contents pane, the corresponding information should be displayed in the right content window, correct?

Any help would be greatly appreciated.

Feb 11, 2008 at 4:26 PM
If you're not seeing anything in the right-hand pane, you're probably running the help file from a network share and a security patch is blocking it. Run it from your C: drive and see if you can view it. If so, see the FAQ in the SHFB help file for a registry setting that you can import to allow you to view the content from a network share.

Feb 11, 2008 at 4:36 PM
That worked!!!! Thanks alot. Documentation looks great. I'll check the FAQ for the network share setting.