errror BE0040, SHFB not honoring solution build configurations

Topics: Developer Forum, User Forum
Jul 7, 2010 at 6:50 PM
Edited Jul 7, 2010 at 6:50 PM

I have SHFB's Documentation Sources node pointed to a solution which contains 25 project files, one of which I do not wish to have documentation generated for (unit tests).  In the release build for this solution, that project file is not built.

When I attempt to generate output from SHFB for the release build, i get this error.

"SHFB: Error BE0040: Project assembly does not exist: C:\Projects\blahblah\bin\Release\AssemblyIWantToExclude.dll"

Does SHFB not honor the build configurations set in the solution?  

This discussion says it will be in the "next build"...

Was that implemented but has some bugs?

I attempted to exclude that namespace through the apifilter and was successful in setting that up (i had to build the debug version in SHFB before it would let me open the apifilter dialog), however SHFB still errors out expecting to find the dll in the release folder.

Any help?

Jul 8, 2010 at 1:36 AM

Are you using the latest release (v1.9.0.0)?  That's when I added the code necessary to honor the build settings in the solution file.  Versions prior to that do not.  I'm going to release an update in a few hours that fixes some unrelated issues (v1.9.1.0).  Give it a try when its available to see if you still have the issue.  If so, if you can e-mail me your *.sln and *.*proj files as a test case, I'll take a look at them.  I won't need any of the code or other files, just enough to see what it's doing when it loads the solution and project files.  My e-mail address is in the About box in the GUI and the footer of the pages in the help file.



Jul 8, 2010 at 4:07 PM

Thanks for the reply Eric.  I deleted the solution and rebuilt it from the ground up and it seems to all be working correctly now.  I'm not really sure what the issue was, a diff of the two files doesn't seem to reveal anything significant.  But then I don't really fully know what to look for. This is a fairly old solution that has been upgraded through a couple of Visual Studio versions, so it may have been attributed to that.

Anyhow, I appreciate all the work you've done, awesome job.

Thank you.

Jul 13, 2010 at 3:34 PM
Hey Eric, I guess this actually isn't working correctly for me now. I inadvertently did a release build of the projects I wanted to exclude, so SHFB was no longer giving me errors about not being able to find the dll's in the bin\release folder, because they now existed. I didn't realize this until recently. I made a dummy solution with three projects, two are build in release, one is not. I encounter the same error as above. I will email these to you. Thanks and I appreciate your assistance.