Support for .NET 4

Topics: Developer Forum
Apr 14, 2010 at 5:29 PM

Will there be any official support for .NET 4 assemblies?

Coordinator
Apr 14, 2010 at 8:12 PM

Version 1.8.0.3 of SHFB in conjunction with the latest Sandcastle Styles patch and the May 2008 release of Sandcastle will support .NET 4.0 assemblies.  Note that the Sandcastle Styles patch is current through VS 2010 RC so you may need to add the RTM version number of .NET 4.0 to the MRefBuilder.exe.config file to get it to work.  There are a couple of problems with code that contains some generic constructs in .NET 4.0 assemblies (it fails to include the members) but we'll have to wait for an official update of Sandcastle to see if those are fixed.

Eric

 

Apr 14, 2010 at 11:18 PM

Awesome, that took care of things. Thanks for the response