This project has moved and is read-only. For the latest updates, please go here.

Can't build with .NET 4.0 RC

Mar 8, 2010 at 4:46 PM


The help file builder worked under .NET 4.0 Beta 2, but with the RC version, it stopped working. When you build the documentation, it can't find any of the .NET 4.0 RC references.

I tried adding these as references, I tried just copying them in the project directory, I've added the path to the .net 4.0 assemblies to the Path environment variable. Nothing seems to help.

I'm thinking that sandcastle itself does not work with the RC version.....

Any help, ideas...


Mar 8, 2010 at 8:11 PM
Edited Mar 8, 2010 at 8:11 PM

You need to update MRefBuilder.exe.config to include the .NET 4.0 version included with VS2010 RC.  I updated the Sandcastle Styles patch yesterday with the necessary change and another unrelated fix.  You can download and apply it again to get the change.



Mar 8, 2010 at 8:14 PM

Thanks Eric. Yeah I saw that and have applied it. And it works now. Great work!

Without you, sandcastle would only be a pile of sand :-)

Mar 16, 2010 at 6:20 PM

I still can't get it to work. I copied the content of your zip-file to C:\Program Files (x86)\Sandcastle however, SHFB still won't build...

Mar 16, 2010 at 6:52 PM

It works now. I have no idea of what I did, but suddenly it just started working...