[Missing <summary> documentation for ....

Topics: User Forum
Oct 24, 2006 at 4:13 AM
Hi, firstly - excellent work! And the ndoc project importer was great to see.

I'm having trouble producing docs without big red

"[Missing <summary> documentation for " text for undocumented members.

How can I stop this being produced?

I have set ShowMissing* to false, but to no avail - the red text is still there.

I am using build 1.3.1.1.

Here's my project file

<project schemaVersion="1.3.1.1">
<assemblies>
<assembly assemblyPath="blah.dll" xmlCommentsPath="blah.xml" />
</assemblies>
<namespaceSummaries>
<namespaceSummaryItem name="" isDocumented="False" />
<namespaceSummaryItem name="MyAssembly" isDocumented="True">Namespace containing main controls and classes.</namespaceSummaryItem>
<namespaceSummaryItem name="MyAssembly.Design" isDocumented="False" />
<namespaceSummaryItem name="MyAssembly.Event" isDocumented="True">Event classes</namespaceSummaryItem>
<namespaceSummaryItem name="MyAssembly.Blah" isDocumented="True">...</namespaceSummaryItem>
<namespaceSummaryItem name="MyAssembly.BlahBlah" isDocumented="True">....</namespaceSummaryItem>
<namespaceSummaryItem name="MyAssembly.BlahBlah.Blah" isDocumented="True">.....</namespaceSummaryItem>
</namespaceSummaries>
<contentPlacement>AboveNamespaces</contentPlacement>
<dependencies>
<dependencyItem depPath="C:\Release\." />
</dependencies>
<projectSummary />
<sandcastlePath />
<hhcPath />
<hxcompPath />
<outputPath>c:\somepath\</outputPath>
<helpFileFormat>HtmlHelp1x</helpFileFormat>
<cleanIntermediates>True</cleanIntermediates>
<purgeDuplicateTopics>True</purgeDuplicateTopics>
<binaryTOC>True</binaryTOC>
<includeFavorites>False</includeFavorites>
<preliminary>False</preliminary>
<rootNSContainer>False</rootNSContainer>
<helpTitle>API</helpTitle>
<htmlHelpName>API Documentation</htmlHelpName>
<language>en-US</language>
<copyrightHref></copyrightHref>
<copyrightText>© Copyright .</copyrightText>
<feedbackEMailAddress>support@blah</feedbackEMailAddress>
<headerText />
<projectLinks>Local</projectLinks>
<sdkLinks>Msdn</sdkLinks>
<presentationStyle>Prototype</presentationStyle>
<missingTags>AutoDocumentCtors</missingTags>
<visibleItems>InheritedMembers, InheritedFrameworkMembers, Protected, SealedProtected</visibleItems>
</project>


I would greatly appreciate any help, as this is a late switch from NDoc to Sandbox, for the .NET 2 support.

Thanks!
Jim
Oct 24, 2006 at 4:25 AM
Hmmm - sorry. I changed some settings (I think only autodocumentconstructors) and now its not marking in red.

Maybe I'm just tired. Maybe settings dont take effect unless you explicitly click save?

It seems to be working now - if I can pin down what makes it not-work/work, I'll post.

Thanks anyway
Jim
Oct 24, 2006 at 4:27 AM
Actually - does HtmlHelp cache pages?? Maybe it does, because I think I've seen lag before with ndoc.

So I probably switched settings but didnt see the effect right away....
Coordinator
Oct 24, 2006 at 4:17 PM
This discussion has been copied to Work Item 4709. You may wish to continue further discussion there.