Error: BuildAssembler

Topics: Developer Forum
Jun 19, 2007 at 9:05 PM
Trying to get it working but i get this error message.

Error: BuildAssembler: An error occured while initializing the build component 'Microsoft.Ddue.Tools.CopyFromIndexComponent' in the component assembly 'C:\Program Files\Sandcastle\ProductionTools\BuildComponents.dll'. The error message and stack trace follows: System.IO.DirectoryNotFoundException: Could not find a part of the path 'C:\Program Files\Sandcastle\Data\Cpref_reflection'.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.Directory.InternalGetFileDirectoryNames(String path, String userPathOriginal, String searchPattern, Boolean includeFiles, Boolean includeDirs, SearchOption searchOption)
at System.IO.Directory.GetFiles(String path, String searchPattern, SearchOption searchOption)
at System.IO.Directory.GetFiles(String path, String searchPattern)
at Microsoft.Ddue.Tools.IndexedDocumentCache.AddDocuments(String wildcardPath)
at Microsoft.Ddue.Tools.IndexedDocumentCache.AddDocuments(String baseDirectory, String wildcardPath, Boolean recurse)
at Microsoft.Ddue.Tools.CopyFromIndexComponent..ctor(BuildAssembler assembler, XPathNavigator configuration)
Last step completed in 00:00:00.8424
Jun 19, 2007 at 10:00 PM
If you want to get this version working with the June CTP you need to use the source code version and make some changes to the sandcastle.config file and to source code (see other threads here)
Jun 20, 2007 at 9:51 AM
Edited Jun 20, 2007 at 1:34 PM
thanks but i installed 2.2.63000.2 and its ok now :o)