1

Closed

Support per-version setting of ripOldApis

description

I'm trying to use the Version Builder plugin for two purposes:
  • For identifying supported versions of the .NET Framework (e.g. .NET Framework 3.5, 4.0, 4.5)
  • For identifying supported versions of the library (e.g. 1.0.0, 1.1.0, 1.1.1, 1.2.0)
For versions listed in the .NET Framework group, I want ripOldApis=false. For versions listed for old releases of the library, I want ripOldApis=true for all versions except for the current release.

I have implemented this feature as part of the following pull request:
https://github.com/tunnelvisionlabs/SHFB/pull/76
Closed Jan 26, 2015 at 6:05 AM by EWoodruff
Moved to GitHub

comments

EWoodruff wrote Aug 29, 2014 at 6:07 PM

Doesn't this change make the existing "rip" option which maps to the "/rip" command line option obsolete? Why would it still be needed? It seems confusing to still have both.

wrote Jan 26, 2015 at 6:05 AM