This project has moved and is read-only. For the latest updates, please go here.

Intermediate files

Topics: Developer Forum, User Forum
Feb 19, 2010 at 9:16 PM

I just started using this  tool. Its awesome and very useful. At this juncture I would like to know how do I modify the build script that is running. I do not want the intermediate files to be removed. But I noticed in the build process of Help 1.x once the .chm file is created the the working folder is deleted. i would want the folder to be there and not deleted.

Kindly let me know where to find the script that drives this process. I looked in tot he templates also. I pretty new to this



Feb 20, 2010 at 3:04 AM

Just set the CleanIntermediates project property to False and the working files will remain after the build.



Feb 22, 2010 at 5:48 PM

Hello Thank you so much. I have the following questions too :

1. I have a big solution which has lot of .dll. I want to build one .chm file for this whole solution rather than individual .chm for each .dlls. Is this possible ? If yes how do I do that?
2. I have problem viewing the generated .chm file. I tried all possible solutions like ( making registry entries and setting the access level) and its still not working. What could be the reason ?



Feb 22, 2010 at 8:48 PM

To document all assemblies produced by all projects in a solution, add the solution (.sln) file as the documentation source.  SHFB will parse the solution file and include all projects for which it can produce help.  Regarding the resulting help file not being viewable, you'll need to be more specific about the problem.  If you can see the TOC but not the content pane, it's probably blocked.  If you copy the help file to your C: drive and open it from there you should be able to view it.



Feb 22, 2010 at 10:04 PM

Oh Ok Let me try the tool with .sln file. 

And w.r.t to viewing the file - I am able to view the TOC but not the content pane even when the .chm file is not on any network drive. I copied the .chm file  to my C drive and I still get the same error. How ever at this juncture I would like to tell u that if I generate my .chm file in sandcastle using the generated ( using SHFB GUI) intermediate files (working directory, .hpp,.hkk,.hcc) I have no problem viewing the .chm file. For this I manually copied the files into C:\Program Files\Sandcastle\ProductionTools\Output and executed the cmd : hhc Output/Help1X.hhp" from command line. 

Also I am trying to write a MS build script and it needs SandcastleBuilderConsole.exe. Where can I download it ?



Feb 23, 2010 at 4:29 PM

SandcastleBuilderConsole.exe is obsolete and was removed starting in v1.8.0.0.  See the Building Projects Outside the GUI topic for information on building the SHFB projects with MSBuild.

Feb 24, 2010 at 9:31 PM


I need urgent help with this error. 
Generating reflection information...
  MrefBuilder (v2.4.10520.1)
  Copyright c Microsoft 2006
  Info: Loaded 52 assemblies for reflection and 99 dependency assemblies.
MREFBUILDER : error : Unresolved assembly reference: nunit.framework (nunit.framework, Version=, Culture=neutral, PublicKeyToken=96d09a1eb7f44a77) required by NUnitAsp
    Last step completed in 00:00:07.0310

SHFB: Error BE0043: Unexpected error detected in last build step.  See output above for details.

I tried the following
1. Added nunit.framework.dll in the the refernces
2. Added nunit.framework.dll in the help/working/ folder



Feb 24, 2010 at 10:21 PM

I also added the GAC refernce

Feb 25, 2010 at 2:46 AM

Make sure you're adding the correct version ( and only one reference for it.  Does the assembly exist anywhere else in your projects?  Check the build log where it's validating all the assemblies and references.  If you see it listed, find the assembly and check its version.  You should probably check all projects that make use of it or the NUnitAsp assembly.  It could be another project is using a newer or older version of the assembly and it is taking precedence.  If that is the case and you can't get them all to use a common version, you might try adding the Assembly Binding Redirection plug-in to the PlugInConfigurations project property to get it to redirect all references to a common version.