This project has moved and is read-only. For the latest updates, please go here.

Unresolved assembly reference

Topics: Project Management Forum, User Forum
Feb 9, 2010 at 1:54 AM
Edited Feb 9, 2010 at 1:54 AM

hi,when i builded the dll ,it appear MREFBUILDER : error : Unresolved assembly reference: Microsoft.SharePoint.Security (Microsoft.SharePoint.Security, Version=, Culture=neutral, PublicKeyToken=71e9bce111e9429c) required by Microsoft.SharePoint
  why?bug?GAC or the problem of version ?


Feb 9, 2010 at 3:07 AM

If it's not finding the indicated assembly automatically, add it as a reference to the project's References node in the Project Explorer window.



Feb 26, 2010 at 7:12 AM

Thanks,yes,i add the reference

Jun 5, 2010 at 4:37 AM
Edited Jun 5, 2010 at 4:41 AM

I'm getting the same error when using .NET 4.0:

Generating reflection information...
  MrefBuilder (v2.4.10520.1)
  Copyright c Microsoft 2006
  Info: Loaded 1 assemblies for reflection and 0 dependency assemblies.
MREFBUILDER : error : Unresolved assembly reference: System.Runtime.Serialization (System.Runtime.Serialization, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089) required by MyClientLib
    Last step completed in 00:00:01.2167

How do I get Sandcastle to look in the GAC for the of System.Runtime.Serialization assembly?  And, yes, I added it to the Reference node in the Project Explorer window, and changed the FrameworkVersion to 4.0.30319.



Jun 5, 2010 at 9:00 PM

Remove the reference to the assembly, download the Sandcastle Styles patch, apply it, and update the MRefBuilder.exe.config file from the patch to add the .NET 4.0 RTM version number.  See this thread for details:



Jun 7, 2010 at 8:24 PM

Thank you, Eric.  Adding that line solved my problem.

If you could add that line to the patch zip file, it would be most helpful to the new users of this great tool.