Additional Reference Links plugin fails

Topics: User Forum
Jan 15, 2010 at 2:33 PM

I have two SHFB projects similar to what is written in the documentation of this plugin here:
http://www.ewoodruff.us/shfbdocs/html/15b6b7be-3778-4487-b524-d558d02e6460.htm

Project "Base" creates documentation for the assembly containing the base classes and project "Ref" creates documentation for an assembly referencing these classes. So I set up two SHFB projects, add the plugin to the .shfbproj of project "Ref" and configure it to include the .shfbproj of project "Base". But upon building I always receive an error:

Applying visibility properties to reflection information file
    22 attribute nodes removed
    0 explicit interface implementations removed
    0 local and base class EII elements removed
Performing partial builds on additional targets' projects

Building C:\..\TestBase.shfbproj
Initializing
FindingTools
ValidatingDocumentationSources
Failed
    Last step completed in 00:00:00.1840
-------------------------------

SHFB: Error BE0029: Unexpected error while executing plug-in 'Additional Reference Links': SandcastleBuilder.Utils.BuilderException: Unable to build additional target project: C:\..\TestBase.shfbproj
   at SandcastleBuilder.PlugIns.AdditionalReferenceLinksPlugIn.Execute(ExecutionContext context)
   at SandcastleBuilder.Utils.BuildEngine.BuildProcess.ExecutePlugIns(ExecutionBehaviors behavior)
Unable to build additional target project: C:\..\TestBase.shfbproj

I am puzzled because TestBase.shfbproj builds fine on its own. Both projects are set to output MS-Help2, to the same output path (I have also tried with different output paths without success). Both project files lie in the same folder and both referenced .csproj files lie in a subfolder of the current folder.

I have installed 1.8.0.3 of the Sandcastle Help File Builder and May 2008 version of Sandcastle patched with Sandcastle May 2008 Patch Rev 3.

Is there something I am missing or doing wrong?

Coordinator
Jan 15, 2010 at 4:32 PM

There should be a build log for the base project that it was trying to build.  Check it to see why it failed.  As I recall, it will be in the Ref project's working folder in a .\PartialBuildLog sub-folder.

Eric

 

Jan 15, 2010 at 5:21 PM

It was using the wrong build configuration of the projects. I thought it would be okay since I have set the combo boxes in the GUI to the proper configuration and platform. Now I entered the Configuration and Platform for every documentation source in "Base" and build works now. Thanks a lot!