Why isn't all my methods included in the generated documentation?

Topics: User Forum
Oct 22, 2009 at 12:55 PM

I am new using Sandcastle, and I may be doing sth wrong.

I have made a SharePoint webpart project.

To document sources I have added the xml file and the solution file.

There are comments to all the methods, but Only 16 out of 24 methods is shown, and 14 of the 16 shows the documentation.

I have checked the XML file, and it contains all the methods with comments.

In SHFB have set all the Visibility properties to true, and I have done the same for the Show Missing Tags. There are no limitations from the ApiFilter.

What am I doing wrong?

Thanks.

Coordinator
Oct 22, 2009 at 3:05 PM

If you add the solution, there's no need to add the XML comments file.  I suppose it's possible one of the comments files is overriding the other and the one that gets picked up isn't complete.  Try adding just the solution, do a full rebuild on it and check the resulting XML comments file to be sure it is complete first then build the help file to see if that has any effect.  Setting all the Visiblity properties to true is usually not necessary unless you truly want all of the related items included.  The defaults are usually sufficient since the rest just clutter the help file unnecessarily.  See the SHFB help file for each property to determine whether or not you really want to change the default setting.  Is this a VB.NET project?  If so, certain elements won't get included due to the way the VB.NET compiler generates them (i.e. public fields with events).  Can you post a small example that doesn't work as expected?

Eric

 

Oct 26, 2009 at 11:36 AM

Thanks for your reply Erik.

I'm a bit embarased. I found the problem now.

The reason why I couldn't extract all of the xml comments was the following;

Under Build options where I have checked the checkbox  XML documentation file. Just above this is the Output path, this output path was different from the path for the xml file.  This is why it didn't work :-(

Hopefully others won't make the same mistake that I did.