Root Namespace summary not rendering in - Prototype Presentation Style

Apr 27, 2009 at 4:05 PM
Hi ,

I currently have installed Sandcastle 2.4.1. and SHFB 1.8 beta . I am trying to build my chm files using the presentation style as "Prototype". But the RootNamespace Container page that is rendered onthe right (which typically lists the namespaces contained inthe chm) is coming as a blank page in the chm. Also the H2X compilation throws an error  "error MSB6006: "HXCOMP.EXE" exited with code 2." . This error is not coming if i build the chm in VS2005 presentation style .

Could you please help me with this? am i missing something?

Regards,
Phalguni.
Coordinator
Apr 27, 2009 at 9:00 PM
If you haven't done so already, apply the Sandcastle Styles patch as it fixes a problem that can cause the root namespace page not to appear.  See http://SandcastleStyles.CodePlex.com.

Eric
Jun 14, 2010 at 4:43 PM

Hi,

I installed the sandcastle styles patch clicking on the given link, downloading it and replacing the folders from those extracted from the archive.

It seems the problem is not solved for me: the page displayed on the root is still blank.

I tried to check the html source code (right-click/view source) and saved it as an HTML file on my machine. If I open the file in IE, i still see a blank page.

If I look at the source HTML Code of the page  and I remove the "<title />" tag place in the body, and then i reopen the HTML file, it works and indeed displays its content.

Can you please tell me how to remove this title tag automatically or how i could solve this problem so that the title tag is affected?

Thanks a lot for your help!

pierre

Coordinator
Jun 14, 2010 at 8:12 PM
Edited Jun 14, 2010 at 8:16 PM

The patch does fix the noted problem which is caused by the blank title element.  If you're not seeing the fix, perhaps the patch didn't get applied.  If you are running Vista or Windows 7, you might check to make sure that there aren't any virtualized copies of the files interfering with the Sandcastle files.  See the documentation page for details.  You might also check to be sure that the DXROOT environment variable is pointing to the proper location.  Also, check your project to make sure the SandcastlePath property isn't pointing to a different copy of Sandcastle.

Eric



Jun 15, 2010 at 10:18 AM

I'm actually running with XP. So that virtualisation issue was not a problem.

However, I tried again to copy the Zip into the installation folder and unpacked it there. And now it indeed works!

I don't really know what was the problem before, but Thank you!

Pierre