Sandcastle not including links to MSDN

Topics: User Forum
Apr 23, 2014 at 8:23 PM
Edited Apr 23, 2014 at 8:24 PM
We have used the Sandcastle Help File Builder to create our projects (chm output). The "Help 1 SDK link type" is set to "Online links to MSDN help topics".
Attributes are visible in the output, but the links are not present. For example:

[ServiceKnownTypeAttribute("...", typeof(KnownTypeProvider))]
public interface ...

I expected "ServiceKnownTypeAttribute" to be a link.

There are no errors in the logs. If anyone knows how to fix this, that'd be very helpful... I've tried following along with the other threads, but nothing seems to solve my issue!
Apr 23, 2014 at 9:10 PM
Links within syntax sections are disabled now by default as they do not work in MS Help Viewer. Also, type information is typically available in the other sections (parameters, returns type, etc.), attributes being the exception. You can enable the links by adding the Syntax Component to the project on the Components property page and, in its configuration, enabling the "render reference links" option.

Apr 25, 2014 at 12:34 PM
Thanks, Eric. I don't actually see the "syntax" component in my Help File Builder... I'm running version I'm guessing that I'm missing something? (Sorry - I'm a tech writer, not a this is probably a pretty silly question! Any help is really appreciated.)
Apr 25, 2014 at 3:10 PM
You just need to upgrade to the latest release. It will allow you to add the Syntax Component to the project.