Syntax filter work not correctlly

Feb 24, 2014 at 8:19 AM
Hello there,

Use version 2014.2.15.0.Beta, select presentation style "VS2010", and syntax filters "C#" and "Visual Basic".
Build help file format only select HTML Help 1 (CHM).

After build help file, I check syntax... it show C#, VB C++ and F#, but I didn't select C++ and F#.
How to remove C++ and F# ?

thanks..
Coordinator
Feb 24, 2014 at 5:13 PM
Unlike the VS2005 style, the VS2010 style always renders the tabs for the four main languages. If any of the languages are not selected in the syntax filter, it will still render those tabs but they will be disabled. It's a limitation of the presentation style and has always worked that way.

Eric
Feb 26, 2014 at 1:34 AM
Is any way let it like Hana style ?
If any of the languages are not selected in the syntax filter, it render default languae (maybe C#, C++..or else).
If have language selected, it only render those selected language.
Coordinator
Feb 26, 2014 at 7:33 PM
No, there isn't. It could probably be done but requires pulling apart the branding transformations to figure out how it's currently done. Those are not something I've looked into that closely.

Eric