This project has moved and is read-only. For the latest updates, please go here.

error MSB6006: "HHC.EXE" exited with code -1073741515.

Topics: Developer Forum, Project Management Forum, User Forum
Jan 10, 2013 at 12:27 PM

Compiling HTML Help 1 file...[C:\Windows\Microsoft.NET\Framework64\v3.5\MSBuild.exe]C:\output\Working\Build1xHelpFile.proj(41,5): error MSB6006: "HHC.EXE" exited with code -1073741515.C:\output\Working\Build1xHelpFile.proj(52,5): error MSB3021: Unable to copy file "C:\output\Working\Output\Documentation.chm" to "C:\output\\Documentation.chm". Could not find file 'C:\output\Working\Output\Documentation.chm'.    Last step completed in 00:00:00.1200-------------------------------
SHFB: Error BE0043: Unexpected error detected in last build step.  See output above for details.

 

i cant able to generate the chm file in my machine.

Sandcastle is showing the above error.It was urgent for me to generate chm file.Please help me

Jan 10, 2013 at 4:12 PM

That error was reported once before and uninstalling and reinstalling the HTML Help Workshop which contains the help compiler corrected it in that case.

Eric

 

Jan 15, 2013 at 10:37 AM

Hi Eric,

Thanks for the reply.

I have done the same for many times.but no result.

i copied hha.dll from the machine where sandcastle is able to generate the chm and copied to my machine.But i got this error:

 

Compiling HTML Help 1 file...[C:\Windows\Microsoft.NET\Framework64\v3.5\MSBuild.exe]

HHC6003 : error : The file Itircl.dll has not been registered correctly.    Microsoft HTML Help Compiler 4.74.8702        Compiling c:\SDISHTML\Working\Output\Documentation.chm                The following files were not compiled:      Last step completed in 00:00:13.6684-------------------------------
SHFB: Error BE0043: Unexpected error detected in last build step.  See output above for details.

 

i tried to register Itircl.dll also (like: regsvr32 Itircl.dll).but no use.

Please help me with the solution.......

Thanks in advance...

Please reply me with an answer

Jan 15, 2013 at 8:05 PM

Sorry, but there isn't anything I can do beyond suggest reinstalling the HTML Help Workshop.  Since it's not a SHFB or Sandcastle issue, it's not something I can fix.

Eric