How to remove "Send Feedback"?

Jan 9, 2013 at 12:04 AM

Hello. I'd like to remove the "Send Feedback" item that is appearing in my help file headers. How is this accomplished? I'm using the VS2010 presentation style. Thank you in advacne.

-L

Coordinator
Jan 9, 2013 at 8:46 PM

There is no "Send Feedback" link in the header of the VS2010 style.  Do you mean the VS2005 style?  If so, the feedback link is part of the resource items for the presentation style so SHFB cannot remove it automatically. You can add a Resource Item file to the SHFB project and edit the "fb_headerFeedBack" resource item to remove the content string which effectively hides the link.  There is a "Send Feedback" link in the footer of the VS2010 style.  Searching the resource items for "feedback" should help you find the equivalent items for that style.

Eric

 

Jan 9, 2013 at 8:54 PM

Thanks for the reply Eric, I may be confused. I'm using the VS2010 presentation style and have "Send Feedback on this topic" in the footer which I don't need to change. However, I also have "Send Feedback" near the top of my conceptual pages (between the page title and introduction block). Is there a way to remove that one?

-L

Coordinator
Jan 9, 2013 at 9:21 PM

I don't see any "Send Feedback" link in the VS2010 headers.  Can you check to be sure you are using the style?  If you see a "Collapse All" and "Code: All" links at the very top of the page, that would be an indication that it's the VS2005 style too.

Eric

 

Jan 9, 2013 at 9:48 PM

Hi Eric, I don't have the "Collapse All" / "Code: All" links as you describe. In SHFB gui-> Help File -> PresentationStyle dropdown I have "VS2010" selected. Any ideas?

-L

Coordinator
Jan 9, 2013 at 10:22 PM

Are you using a customized version of the presentation style?  Are you perhaps using a prior version of SHFB with the SelfBranded option set to false?  You might check your SHFB project file and if you see a SelfBranded property, delete it though it shouldn't interfere with anything since those options are hard-coded to turn it off in the latest release.  You might try uninstalling Sandcastle and making sure the \Program Files (x86)\Sandcastle folder is gone then reinstall to make sure nothing is hanging around from an older version.

Eric

 

Jan 9, 2013 at 11:03 PM

Well...I'm using a "Post-transform Component" to insert a logo, but that's it. I think I'll give up on this modification for now.

One more question...should I have a "Colorizer" folder in the Sandcastle folder? I can't see one and I'd like to try the advice you gave in this thread:

http://shfb.codeplex.com/discussions/393426

Thank you in advance, L

Coordinator
Jan 10, 2013 at 3:12 AM

Okay, you are using an older version as the Post-Transform component has been superceded by the Transform Arguments property page in v1.9.6.0.  There were some problems with the SelfBranded property in earlier releases so that's probably what you are running into.  The link you are seeing is coming from the help viewer not the Sandcastle transformations.  It won't appear when built with the latest release.  Also, the latest release lets you place the logo wherever you want, not just on the right in the VS2010 style.

The Colorizer folder is part of SHFB so you'll find it in its installation folder (C:\Program Files (x86)\EWSoftware\Sandcastle Help File Builder).  If you add the Code Block Component to your project, you can override the syntax rules file it uses.  Modifying the one in the SHFB folder will make the changes permanent for all projects.

Eric

Jan 11, 2013 at 9:34 PM

Thanks Eric, both issues have been resolved thanks to your suggestions.

-L