This project has moved and is read-only. For the latest updates, please go here.

The Microsoft Help File Viewer in VS dont show me my documentation

Topics: Developer Forum, User Forum
Dec 27, 2012 at 9:21 AM
Edited Dec 27, 2012 at 9:22 AM

Hello Im from Germany and try to work with Sandcastle, till the last 3 months. I will show you the steps after which I proceeded.

I work with a Windows Server 2008 VM with Visual Studio 2010 Vers. 10.0.40219.1 SP1Rel .NET Framework 4.0

Firstly i installed sandcastle and the help file builder v., (but i had other versions before). Than i created a testapplication which opens a console and show the word hello. After that i documented the code with xml comments. In the next step i activate the check box at the properties from the project for the build of the xml data, and build the csharp project.

The next step were the settings in the help file builder. I have screenshots of that, if you need please give me an email adress. I changed Syntax Filters to CSharp, the vendor name, the product title, HelpFileFormat to MSHelpViewer, the output path and set some "show missing tags" to false.

In the next step i builded the sandcastleproject and executed the Install_Documentation.bat. It seemed as if everything works, but i know that at this step, sometimes i will asked if i want to proceed Yes/No but this question no longer appears.

If i go now on manage help settings and check for updates online, in visual studio, i can see there my documentation, but if i press F1 on a documented and highlited method the help viewer will opened an show my the message "Can't find requested content on your computer".

If i open the help normally, my topic won't be shown in the treeview.

If you can help my i would be very happy, because the documentation of source code is very important for us, if you need a i have screenshots of all steps and settings.


Dec 27, 2012 at 12:57 PM

Two common problems are:

- You have chosen online help as help preference

- You haven't set the documentation store in the Help Viewer ("Help"->"manage Help Settings" -> "Settings" -> "I Want to use local help" -> Confirm the library location). If you have done this before, verify that the location actually exists.

Does the "Manage Help Content" Dialog appear when you are executing the batch file? AFAIK, there is no silent installation for VS 2010, so you'll always have to go through the dialog. If it does not appear, there is some other problem, I guess. You can also manually add the MSHC from this dialog.

Of course there can be a whole lot of other problems, but I'd check these first.

Dec 27, 2012 at 1:24 PM
Edited Dec 27, 2012 at 1:25 PM

Hey thanks for the answer. I choosed local help all the time and the path is correctly, the normal help works fine.

The "Add Content From Disk" Window from the Help Library Manger is there also and i can Add and Update the help. I meant that there comes no question if i want to proceed while updating. He updates, all shows fine and finish. But in the past, the manager asked me if i want to proceed, while updating, i don't know if this is important.

I will try now to uninstall sandcastle and the Help File Builder and install the newest version.

Dec 28, 2012 at 10:58 AM

Hello again,

today i tried the newest version, with the last version it did not want to run, no matter what i did. All the time i saw only "cant find requested content on your computer" in the help viewer. And now with the new Version it looks as if everything works perfectly. The testproject works fine and the first bigger project which i documented, works also fine. I will try more projects.

Im happy about that :).


Jan 2, 2013 at 9:54 AM
Edited Jan 2, 2013 at 12:47 PM

Okay now i have a new problem, if i press F1 on a documented method which exists with a simmular name in a other namespace from microsoft, the help viewer always only show me the documentation from microsoft from the wrong namespace. For example i have documented a method which is named Execute(), if i highlight this method and press "F1" the help viewer shows me the documentation for "GetAssemblyIdentity.Execute" from the Micrsoft.Build.Tasks namespace. But if i search for my documentation manually, i can find it in the help. But my target is a documentation that works with the "F1" button.

I've got the Microsoft Help Viewer 1.1 can that be a reason for this problem?

Hope someone can help me.


Jan 9, 2013 at 1:57 PM

Hello again,

can someone help me with that problem? I consider to contact the Microsoftsupport for that problem, because I think the problems reason is maybe the linking from the Help Viewer.


Jan 9, 2013 at 8:48 PM

I created a quick example based on your description but it worked fine and the correct topic was displayed when F1 was hit.  If you can send me a small example that demonstrates the problem, I'll look into it.  My e-mail address is in the About box in the standalone GUI and in the footer of the pages in the SHFB help file.