SHFB 1.9.4: Could not load file or assembly 'SandcastleBuilder.Utils, Version=1.9.3.0....

Topics: Developer Forum
Jun 29, 2012 at 6:56 AM

Every since I removed the previous version of SHFB and Sandcastle and installed the new one, the first time I open my project and press Build (just chm if this matters) I get the following error:

-------------------------------[Sandcastle Help File Builder, version 1.9.4.0]Creating output and working folders...Loading and initializing plug-ins...    Last step completed in 00:00:00.1180-------------------------------
SHFB: Error BE0028: Plug-in loading errors:Unable to load plug-in assembly for Additional Content Only:  Assembly: C:\Program Files (x86)\EWSoftware\Sandcastle Help File Builder\PlugIns\BuildFlagPlugIn.plugins  Could not load file or assembly 'SandcastleBuilder.Utils, Version=1.9.3.0, Culture=neutral, PublicKeyToken=71c06e0a0c1c8bf2' or one of its dependencies. The system cannot find the file specified.

Note that this happens when I press the build button for the first time since the proj is opened. Afterwards (second, third and so on) the build is executed and performed correctly.

Why would it look for a 9.3 version of this plug in? Where can I get the new one and where should I replace it?

Coordinator
Jun 29, 2012 at 4:08 PM

BuildFlagPlugIns appears to be a custom plug-in assembly build against the prior release of SHFB.  It needs to be rebuilt using the latest SHFB assembly references.  If you don't use it and it isn't referenced by your project, you can simply delete it from the indicated folder if it didn't come with an MSI installer.  It's not one I'm familiar with so I don't know where it came from.

Eric

 

Jul 31, 2012 at 7:42 AM

Thanks for your answer. It is a custom plugin and I will rebuild it as described.