Can't find requested content on your computer

Topics: User Forum
Apr 30, 2012 at 3:37 PM

Hi.  I have built and installed the help files produced by SandCastle into the Microsoft Help Viewer 1.1 (Visual Studio 2010 with service pack 1).

When I click F1 over my classes/methods in VS2010 IDE, I get "Topic not found / Can't find requested content on your computer" in the right pane of MSHelp Viewer.

However in the left pane I get the topics i need and they work as expected.

Any ideas out there ?

Thanks.

DIEGO.

 

May 3, 2012 at 10:38 PM

Same problem here.  I tried everything including deleting the entire local help system.  I finally realized the problem must be in the documentation project itself.

I deleted the documentation project from my solution and created a new one from scratch, and then it worked fine.  Now I'm wondering exactly what change I made that screwed it up.  I'm going to make one change at a time and verify it to see if I can catch when it happened.

May 4, 2012 at 1:40 PM

Hi. Thanks for your response, i've recreated the project, but i get the same behaviour.

When i click F1 in Visual Studio the left pane of Help Viewer 1.1 shows all my topics, but the right pane shows "Can't find requested content on your computer".

Once i click into some of the left pane topics, then the navigation works very well for all the classes, interfaces, methods and so on.

 

My only issue is with F1 in Visual Studio 2010 to start looking at the help files.

Thanks a lot

May 4, 2012 at 4:57 PM

I found that the one setting that caused it to consistently produce the "Can't find requested content on your computer" problem is setting the presentation style to "vs2010".  If I set it to "vs2005", then it works fine.

 

May 4, 2012 at 6:05 PM

Thanks again Mycoda, but unfortunately it still doesn't work, neither with vs2005 nor vs2010 style.

Unfortunately i can't paste a screenshot in this discussion list to better explain my issue.

May 10, 2012 at 1:58 PM

Hi.

 

I have uploaded some screenshots to Skydrive to better document my issue.

You can see there what i get when i do F1 over some objects in my VS2010 source code.

Thanks you all, and i hope some of you could have a clue.

DIEGO

 

https://skydrive.live.com/redir.aspx?cid=36e21df2f94c8276&resid=36E21DF2F94C8276!462&parid=36E21DF2F94C8276!117

May 16, 2012 at 7:29 PM

I've got exactly the same problem..

another thing I noticed is that the issue happens for vs2010 style only. If I build the same project using "prototype" or "hana" styles - everything works fine.

I would appreciate any help,

thanks

 

 

May 17, 2012 at 1:09 PM

Thanks for your clue Zvainer.

I've tested with prototype and hana styles and effectively (as you say) it works as expected, but the presentation is ugly.

Otherwise the vs2010 presentation style is good-looking but it doesn't work.

 

Anyone else has a suggestion ?

Maybe we should wait the next release of Sandcastle HFB.

Thanks !

DIEGO.

 

Coordinator
May 17, 2012 at 3:13 PM

I replied to the related thread in the Sandcastle project here: http://sandcastle.codeplex.com/discussions/356062

Eric

 

Oct 9, 2012 at 6:36 PM

Hi.

I've installed SHFB 1.9.5.0 today but i get the same wrong behaviour. Any ideas on how to solve this issue ?

 

Thanks

DIEGO.

Coordinator
Oct 10, 2012 at 3:42 AM
Edited Oct 10, 2012 at 3:43 AM

Sorry, I didn't make a note to follow up on the problem and missed it.  I've fixed the affected transformations and they are in the latest check-in.  I'll probably publish a refresh containing the changes this weekend.

Eric

 

Oct 10, 2012 at 12:55 PM
Thanks for your quick response.

I'm eager to test this fix with VS2010, we are currently using Sandcastle with VS2008 and it works very well.

Have a nice day.

Diego.


From: [email removed]
To: [email removed]
Date: Tue, 9 Oct 2012 20:42:54 -0700
Subject: Re: Can't find requested content on your computer [SHFB:354027]

From: EWoodruff
Sorry, I didn't make a note to follow up on the problem and missed it. I've fixed the affected transformations and their in the latest check-in. I'll probably publish a refresh containing the changes this weekend.
Eric

Read the full discussion online.
To add a post to this discussion, reply to this email (SHFB@discussions.codeplex.com)
To start a new discussion for this project, email SHFB@discussions.codeplex.com
You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.
Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com
Oct 18, 2012 at 2:54 PM

Voila, with the last fix (OCT 13 2012) it works very well. I've tested my examples and everything works as expected.

 

Thank you and continue with this useful and excellent tool.

DIEGO

Nov 7, 2012 at 7:08 PM
Edited Nov 7, 2012 at 9:51 PM

I just completely uninstalled my earlier version of SHFB, downloaded the 1.9.5.0 Oct 13, 2012 version of SHFB.  And still got the problem that DIEGO had.  The navigation pane works very well but the right pane always shows "Can't find requested content on your computer" message.

Selecting the standard help from VS2010 or other third party help such as "ODAC Documentation for Visual Studio" works fine.

Where have I gone wrong?  Of course, I want vs2010 style.

 

Nov 7, 2012 at 9:55 PM

Here is my project file:

<?xml version="1.0" encoding="utf-8"?>
<Project DefaultTargets="Build" xmlns="http://schemas.microsoft.com/developer/msbuild/2003" ToolsVersion="4.0">
  <PropertyGroup>
    <!-- The configuration and platform will be used to determine which
         assemblies to include from solution and project documentation
         sources -->
    <Configuration Condition=" '$(Configuration)' == '' ">Debug</Configuration>
    <Platform Condition=" '$(Platform)' == '' ">AnyCPU</Platform>
    <SchemaVersion>2.0</SchemaVersion>
    <ProjectGuid>{c0be6a2f-2ede-4db7-a9cc-b67c25688ad7}</ProjectGuid>
    <SHFBSchemaVersion>1.9.5.0</SHFBSchemaVersion>
    <!-- AssemblyName, Name, and RootNamespace are not used by SHFB but Visual
         Studio adds them anyway -->
    <AssemblyName>Documentation</AssemblyName>
    <RootNamespace>Documentation</RootNamespace>
    <Name>Documentation</Name>
    <!-- SHFB properties -->
    <OutputPath>.\Help\</OutputPath>
    <HtmlHelpName>Documentation</HtmlHelpName>
    <Language>en-US</Language>
    <HelpFileFormat>HtmlHelp1, MSHelpViewer, Website</HelpFileFormat>
    <CopyrightText>%28c%29 2012 Inc.</CopyrightText>
    <HelpTitle>Data Service Class Library</HelpTitle>
    <Preliminary>True</Preliminary>
    <PresentationStyle>vs2010</PresentationStyle>
    <DocumentationSources>
      <DocumentationSource sourceFile="DataService.Contracts\bin\Release\DataService.Contracts.dll" xmlns="" />
      <DocumentationSource sourceFile="DataService.Contracts\bin\Release\DataService.Contracts.xml" xmlns="" />
    </DocumentationSources>
    <VisibleItems>InheritedMembers, InheritedFrameworkMembers, Protected, SealedProtected</VisibleItems>
    <MissingTags>Summary, Parameter, Returns, Remarks, AutoDocumentCtors, Namespace, TypeParameter, IncludeTargets, AutoDocumentDispose</MissingTags>
    <VendorName>Inc_</VendorName>
    <NamespaceSummaries>
      <NamespaceSummaryItem name="DataService.Contracts" isDocumented="True">This contract Interface defines the methods and the request/response structures that are used to do transactions with Data Service.</NamespaceSummaryItem>
      <NamespaceSummaryItem name="(global)" isDocumented="True" />
    </NamespaceSummaries>
  </PropertyGroup>
  <!-- There are no properties for these groups.  AnyCPU needs to appear in
       order for Visual Studio to perform the build.  The others are optional

       common platform types that may appear. -->
  <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Debug|AnyCPU' ">
  </PropertyGroup>
  <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Release|AnyCPU' ">
  </PropertyGroup>
  <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Debug|x86' ">
  </PropertyGroup>
  <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Release|x86' ">
  </PropertyGroup>
  <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Debug|x64' ">
  </PropertyGroup>
  <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Release|x64' ">
  </PropertyGroup>
  <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Debug|Win32' ">
  </PropertyGroup>
  <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Release|Win32' ">
  </PropertyGroup>
  <!-- Import the SHFB build targets -->
  <Import Project="$(SHFBROOT)\SandcastleHelpFileBuilder.targets" />
</Project>

 

Coordinator
Nov 7, 2012 at 10:55 PM

You need to uninstall Sandcastle as well and reinstall it.  The changes that affect this issue were made there.

Eric

 

Nov 8, 2012 at 3:47 PM

I did, what I mean by "completely uninstalled my earlier version of SHFB" is to go to control panel and uninstall both the File Builder and the compiler.  I also went to C:\Program Files (x86) and remove the appropriate folders.

Coordinator
Nov 8, 2012 at 3:59 PM

Sorry, but to be clear, when you say "compiler" do you mean the HTML Help Compiler or the Sandcastle Tools.  The Sandcastle Tools are what count.  As long as you removed them, there shouldn't be an issue.

Eric

 

Nov 8, 2012 at 5:19 PM

I did mean SandCastle tools.  I am going to reinstall them again today and let you know the outcome.

Nov 8, 2012 at 6:06 PM

I removed my help topic from the Help Manager, I uninstalled both SandCastle Tools and SHFB, goto program files and remove the empty SandCastle folder there (SHFB did its clean up well).  Delete my help folder. Reinstalled SHFB and installing everything except support for MSHelp2 since I am using vs2010.  Recompile my help file using SHFB, run the Install batch to rename the file my Documentation.msha to HelpContextSetup.msha and exit Help Library Manager. Launch Help Library Manager from vs2010 and install my help topic.

Result is the same as before.  Where did I go wrong?  I am starting to envy DIEGO now.

Coordinator
Nov 8, 2012 at 7:24 PM

It looks like you've done everything right.  If you like, you can send me an example project that fails and I'll see if there's something specific to the project that's causing an issue.  My e-mail address is in the footer of the pages in the help file and the About box in the standalone GUI.

Eric