Self-branding for vs2010 presentation style

Topics: User Forum
Apr 17, 2012 at 8:07 AM

I was curious about the new vs2010 presentation style, how ever, when I switch to it, I get the following error message(s) upon build:

BUILDASSEMBLER : error : BrandingComponent: Self-branding is required for Website help format.

Any ideas how I can configure self-branding? I didn't find too much Googling nor looking in the SHFB helpfile.

I'm using shfb 1.7.4.0 and Sandcastle Documentation Compiler tools 2.7.0.0

Coordinator
Apr 17, 2012 at 3:03 PM

Set the SelfBranded project property to True.  It gets set to False by default when the VS2010 style is selected.  Once set back to True, it will build.

Eric

 

Apr 17, 2012 at 5:46 PM

Thanks for your answer, it's running as I type.

I'm right that this doesn't reflect in the GUI of SHFB right? I changed it in the project file,

Coordinator
Apr 17, 2012 at 7:24 PM

The project property is exposed in the GUI.  It's in the MS Help Viewer category of properties.  In Visual Studio, it's a checkbox and is more descriptive "The help file is self-branded".

Eric

 

 

Apr 18, 2012 at 7:46 AM

Ah I overlooked it, I thought the property was somehow cross-target and would not be listed there.

Apr 18, 2012 at 1:18 PM
Edited Apr 18, 2012 at 1:20 PM

I'm having trouble building with the vs2010 style too. Building with vs2005 style works ok; vs2010 results in:

  Info: BrandingComponent: Instantiating component.
BUILDASSEMBLER : error : BrandingComponent: Self-branding is required for HtmlHelp1 help format. [D:\***\dev\Help\Output\Working\BuildReferenceTopics.proj]
    Last step completed in 00:00:39.2790
-------------------------------

SHFB: Error BE0043: Unexpected error detected in last build step.  See output above for details.

My settings are as follows:

As you can see I set SelfBranded to true. Also note the "tip" at the bottom; this specifically states that the SelfBranded property should (typically) be set to "false if the 'VS' catalog is used and true otherwise". From what I understand I seem to be using the "VS" catalog (as seen in CatalogProductId; it is not clear to me if that is the same as '"VS" catalog' or some seemingly similar property). But it doesn't matter if I set the SelfBranded property to true or false; either setting will result in this error.

Is there something else I can check/change/do to fix this? Please advise?

Coordinator
Apr 18, 2012 at 3:15 PM

Save, close, and re-open the project.  I've seen a couple of cases where changes don't always get flushed to the project before it's built.  I can't seem to duplicate the issue but it could be a combination of settings that I don't have set.  If it still doesn't work, can you e-mail me a small example?  My e-mail address is in the About box in the GUI and in the footer of the pages in the help file.

Eric

 

Apr 21, 2012 at 8:44 PM

Seriously, there's something else though, I keep getting this error although I managed to have a new project build after fiddling around, closing and reopening, pressing Ctrl+Shift+S before build, etc...

The project that I care about just won't build... I'm guessing maybe the setting is copied to some other places and not being updated at all or something...

I'll demonstrate the problem:

From command line, with VS closed (I didn't mark the whole width of the console, so there's some lines partially missing):

C:\Docs>more Docs.shfbproj

   <IndentHtml>True</IndentHtml>
   <NamingMethod>MemberName</NamingMethod>
   <Preliminary>True</Preliminary>
   <SyntaxFilters>Standard</SyntaxFilters>
   <CollectionTocStyle>Hierarchical</Collect
   <SelfBranded>True</SelfBranded>
   <VendorName>me</VendorName>
   <WorkingPath>Temp\</WorkingPath>
   <DocumentationSources>
     <DocumentationSource sourceFile="..\Com

(...)

C:\Docs> msbuild Docs.shfbproj

(...)

  BuildConceptualTopics
SHFB : error BE0043: Unexpected error detected in last build step.  See output
above for details. [C:\Docs\Docs.shfbproj]
  Failed
  Build details can be found in C:\Docs\Log.txt
Done Building Project "C:\Docs\Docs.shfbproj" (default ta
rgets) -- FAILED.


Build FAILED.

"C:\Docs\Docs.shfbproj" (default target) (1) ->
(CoreBuildHelp target) ->
  SHFB : error BE0043: Unexpected error detected in last build step.  See outpu
t above for details. [C:\Docs\Docs.shfbproj]

    0 Warning(s)
    1 Error(s)

Time Elapsed 00:00:27.66

...

and in log.txt

  Info: CachedResolveReferenceLinksComponent: Searching directory &#39;C:\Docs\T
emp&#39; for targets files of the form &#39;reflection.xml&#39;.
  Info: CachedResolveReferenceLinksComponent: Loaded 195255 reference targets.
  Info: CachedResolveReferenceLinksComponent:
      [Sandcastle Help File Builder, version 1.9.4.0]
      Cached Resolve Reference  Links 2 Component.  Copyright &#169; 2006-2012,
Eric Woodruff, All Rights Reserved
      http://SHFB.CodePlex.com
  Info: CachedResolveReferenceLinksComponent: Loaded 687 cached MSDN URL entries
  Info: IfThenComponent: Instantiating component.
  Info: BrandingComponent: Instantiating component.
BUILDASSEMBLER : error : BrandingComponent: Self-branding is required for HtmlHe
lp1 help format. [C:\Docs\Temp\BuildConceptualTopics.proj]
    Last step completed in 00:00:17.1957
</buildStep>
<buildStep step="Failed">

SHFB: Error BE0043: Unexpected error detected in last build step.  See output ab
ove for details.

</buildStep>
</shfbBuild>

Apr 21, 2012 at 8:54 PM

Also tried to disable anything smelling after caching and I tried putting the checkbox to false (checking the shfbproj with more to see whether it committed to disk) then putting it back to true...

It just won't build.

Coordinator
Apr 22, 2012 at 12:28 AM

Can you send me an example that demonstrates the issue?  That would help me track down the problem with something I can actually test.  My e-mail address is in the About box in the GUI and the footer of the pages in the help file.

Eric

 

Apr 28, 2012 at 1:36 PM
Edited Apr 28, 2012 at 1:37 PM

See my answer at http://sandcastle.codeplex.com/discussions/352390

Coordinator
Apr 28, 2012 at 6:32 PM

I'll have this fixed and a refresh published sometime tomorrow.  The basic problem is a misunderstanding on my part on how the self-branded property was to be used.  In the current release, it's being forced to false when the VS2010 style is selected which is incorrect.  There's also a problem in how it's used in the configuration file templates for non-MS Help Viewer output.  In reality, it should always be left set to true unless you want some default branding applied by the help viewer which typically is not what you'd want.  Once the refresh is published and you've installed it, set the SelfBranded property back to true/checked and all should be well.

Eric

 

Apr 30, 2012 at 11:38 PM
Thanks Eric,
Is it enough to run the Guided Installation dated April 29th and installing the vsix with it? The wizard states SHFB as well as Sandcastle 2.7 are ‘found’ which leaves me doubting whether they are up to date. Which of those two components should I manually remove so the wizard allows me to reinstall, if any?
Thanks,
Eric
From: [email removed]
Sent: Saturday, April 28, 2012 8:32 PM
To: [email removed]
Subject: Re: Self-branding for vs2010 presentation style [SHFB:352524]

From: EWoodruff

I'll have this fixed and a refresh published sometime tomorrow. The basic problem is a misunderstanding on my part on how the self-branded property was to be used. In the current release, it's being forced to false when the VS2010 style is selected which is incorrect. There's also a problem in how it's used in the configuration file templates for non-MS Help Viewer output. In reality, it should always be left set to true unless you want some default branding applied by the help viewer which typically is not what you'd want. Once the refresh is published and you've installed it, set the SelfBranded property back to true/checked and all should be well.

Eric

Coordinator
May 1, 2012 at 1:59 AM
Edited May 1, 2012 at 2:26 AM

I didn't change Sandcastle itself, so it doesn't need removing and reinstalling.  I did change SHFB but kept the version number the same since not many people are affected by the update.  As such, you do need to remove SHFB before reinstalling as the guided installer will see the same version and not bother forcing an installation.  The VSIX contains a couple of changes so it should be installed again too.  The VSIX page doesn't do version checking as there isn't an easy way to do it so installing it will remove it first if it's there and install the one that comes with the installer whether its new or the same version.

Eric

 

May 1, 2012 at 4:29 AM
Awesome ty ;)
From: [email removed]
Sent: Tuesday, May 01, 2012 4:00 AM
To: [email removed]
Subject: Re: Self-branding for vs2010 presentation style [SHFB:352524]

From: EWoodruff

I didn't change Sandcastle itself, so it doesn't need removing and reinstalling. I did change SHFB but kept the version number the same since not many people are affected by the update. As such, you do need to remove SHFB before reinstalling as the guided installer will see the same version and not bother forcing and installation. The VSIX contains a couple of changes to it should be installed again too. The page doesn't do version checking as there isn't an easy way to do it so installing it will remove it first if it's there and install the one that comes with the installer whether its new or the same version.

Eric