Language filters not working correctly

Topics: User Forum
Dec 27, 2006 at 5:12 AM
If I enter CSharp, VisualBasic, CPlusPlus for the syntax filter, it is being automatically replaced by Standard. The selections in the help file are then VB, C#, C++, J#, JScript, XAML.

All I wanted was VB, C# and C++.


The following is then generated in the reference_content.xml file.


<!-- language filter
-->

<item id="languageFilter">Language Filter: {0}</item>

<item id="all">All</item>

<item id="multiple">Multiple</item>

<item id="VisualBasic">Visual Basic</item>

<item id="VBScript">Visual Basic Script</item>

<item id="CSharp">C#</item>

<item id="ManagedCPlusPlus">C++</item>

<item id="JSharp">J#</item>

<item id="JScript">JScript</item>

<item id="xml">Xml</item>

<item id="html">Html</item>

- <item id="visualbasicANDcsharp">
<include item="VisualBasic" />
and
<include item="CSharp" />
</item>

<item id="other" />

<item id="XAML">XAML</item>

<item id="usage">Usage</item>

- <item id="VisualBasicDeclaration">
<include item="VisualBasic" />
(Declaration)
</item>

- <item id="VisualBasicUsage">
<include item="VisualBasic" />
(
<include item="usage" />
)
</item>
Dec 27, 2006 at 3:40 PM
This might be a Sandcastle problem as the correct list shows up in the ProtoType format.

Coordinator
Dec 27, 2006 at 8:11 PM
I only alter the dropdown in the Prototype style. The language filter in the VS2005 style is a div as I recall and there's more involved in removing the items so I left it out for the time being. The C#, VB.NET, C++, and J# code blocks are connected to the related items in the popup and will show or hide as you check and uncheck the items. The other non-represented languages are just there but have no effect.

Eric