HTML Additional Content in MSHC

Topics: Developer Forum
Aug 27, 2011 at 12:20 PM

Dear All,

I am facing the proplem with HTML Additional content files.

I have added the see href tag in the XML comments. And while building MSHC file using Sandcastle Help File Builder Version 1.9.3.0 the html link (for Additonal Content html) is not opening.

It is showing the following the URL but dispalying 404 error.

http://127.0.0.1:47873/help/0-1612/Testing.htm

Could any one help on this? How to solve the issue?

Regards,

Sundar.

Coordinator
Aug 27, 2011 at 8:43 PM

Be aware that HTML additional content is not supported in MS Help Viewer output.  There are just too many requirements to make it work properly and SHFB will make no effort to do so.  You must convert to MAML topics so that the rendered HTML contains all of the necessary elements.  The HTML additional content model has been deprecated for quite a while and will receive no further updates.

As for linking from XML comments to conceptual content, MS Help Viewer presents a bit of a problem as it uses ms-xhelp style links that are not compatible with other help file formats.  It was discussed in this thread (http://shfb.codeplex.com/discussions/214188) a while ago but I haven't looked into it further nor has anyone else as far as I know.  In theory, you may be able to look at an API topic in the working folder after a build (set the CleanIntermediates project property to false) and copy the ms-xhelp link format from there and use it with the appropriate ID in the XML comments.  When the viewer renders the topic for display it adds the "http:" prefix and other attributes so I know copying a link from a topic rendered by the viewer is not the way to do it.

Eric

 

Aug 29, 2011 at 4:38 AM

Eric, Thank you very much for your kind information.