Setting DocumentationSource from command line doesn't work

Topics: User Forum
Mar 25, 2011 at 10:48 AM

I've tried setting documentationsource from command line using:

/p:DocumentationSources="<DocumentationSource sourceFile='path/to/dlls' />"

But however I do I get the following error:

SHFB : error BE0039: The project does not have any documentation sources defined

What's weird though is that if I set the exact same documentsources in the shfbproj file it works. And when I pass that parameter in, I get that error.

Any ideas what may be wrong?

Coordinator
Mar 25, 2011 at 3:59 PM

There's a problem with command line overridden options in the v1.9.3.0 release reported in this work item: http://shfb.codeplex.com/workitem/30301.  I've fixed it and will release an update soon.  In the meantime, you can work around it by putting the options in an target override file and specifying it's name using the /p:CustomBeforeSHFBTargets=fullPathToOverridesFile.  See this help topic for info on how to create the target override file: http://www.ewoodruff.us/shfbdocs/Index.aspx?topic=html/8ffc0d37-0215-4609-b6f8-dba53a6c5063.htm

Eric

Mar 28, 2011 at 8:27 AM

I tried the latest 03/26/2011 Refresh and it works great. Thanks!