Build Failed

Topics: Developer Forum, User Forum
Mar 28, 2008 at 4:42 PM
I hadn't used the GUI in about a week and just tried to Build Project and got

BUILD FAILED: Your version of Sandcastle is out of date (found '1.0.0.0' but expected '2.4.10111.0'). Please download and install the latest version.

But I have the latest version, from Jan 2008. I uninstalled and re-installed, but still no go.

Any suggestions?
Coordinator
Mar 28, 2008 at 5:04 PM
You've probably installed the Visual Studio SDK which contains an outdated version of Sandcastle. You will need to edit the environment variables to get rid of the User copy of DXROOT and may need to edit the System copy of DXROOT to point at the regular installation of Sandcastle (C:\Program Files\Sandcastle). You may need to reboot in order for the changes to take effect.

Eric
Mar 31, 2008 at 7:16 PM
Thanks! Yes that was it. I just needed to change the User copy of DXROOT.


EWoodruff wrote:
You've probably installed the Visual Studio SDK which contains an outdated version of Sandcastle. You will need to edit the environment variables to get rid of the User copy of DXROOT and may need to edit the System copy of DXROOT to point at the regular installation of Sandcastle (C:\Program Files\Sandcastle). You may need to reboot in order for the changes to take effect.

Eric