Reg_Filter in the Help2 ini file

Topics: Developer Forum, User Forum
Nov 30, 2010 at 11:49 AM


I have a Sandcastle project file and I want to build Help2 documentation from it. The HelpAttributes that I have set in the project are

      <HelpAttribute name="MyHelpAttribute" value="MyProductNamespace" />

When I build the Help2 profile of the documentation, I get the following line for the [Reg_Filter] in the ini file produced by the build:


However, in order to get my documentation visible and registered correctly, the line should actually look like this:


When I replace the line manually in the ini and try to register the Help2, I get my documentation. However, I want to get the correct ini automatically without any manual modifications.

Could you please let me know why I am not getting the expected ini and how this can be changed from the Help Builder interface?

Thank you very much! Keep up the good work.

Dec 1, 2010 at 7:29 PM

The "DocSet" value is hard coded in the template file.  It's the one most commonly used and covers most situations.  You will need to edit the end result manually if you want to use a non-standard attribute name.



Dec 2, 2010 at 3:40 PM

Thank you for replying, Eric.

Since I cannot use a custom attribute, I will use the default one. However, the reason I started using a custom attribute is that the default one does not seem to work propertly for me.

Since this forum does not allow attachments, please find a short movie of my tests here: (check the checkbox and then click the green button to download the movie). For this movie I am using a newly created project which uses only the default settings. After I build the Help2 files I register them and then I try to view my sample documentation. However, the sample article that I created does not show up. Most probably, I am missing something basic here, but I can't understand what. Could you please let me know what is wrong in my scenario and why my sample article does not want to show?

Best regards,


Dec 9, 2010 at 2:09 AM

For filtering to work correctly, I believe you need to open the editor for the HelpAttributes project property and click the Default button so that it adds the required attribute to the topics.