Error HXC3031: A group of keywords for a single Help link or KTable exceeds 4,096 bytes.

Topics: User Forum
Nov 14, 2006 at 6:24 AM
I get the following error while building the documentation for a really large assembly.

Error HXC3031: A group of keywords for a single Help link or KTable exceeds 4,096 bytes.

I am using the November CTP release of Sandcastle along with the "Sandcastle Help File Builder" tool.

Any idea how to go about resolving this one?

Thanks,
Sanchit Bahal

Coordinator
Nov 14, 2006 at 4:09 PM
This is probably a help compiler issue. Ask in the MSDN documentation forum.

Eric
Nov 28, 2006 at 5:58 AM
Hi Eric,

I posted this topic on the MSDN forum - http://forums.microsoft.com/MSDN/showpost.aspx?postid=958324&SiteID=1

As suggested by Anand, I tried this scenario without using the SHFB tool and did not get any errors this time.

I am also getting additional warnings when using the SHFB tool which do not come when I use Sandcastle directly.

Thanks,
Sanchit Bahal.
Coordinator
Nov 28, 2006 at 4:09 PM
Can you send me a demo project and files that duplicate the error?
Dec 6, 2006 at 5:15 PM
I see this problem too. I think it may have to do with too many param values being empty like this:

/// <param name="parameter"></param>

At least, when I fill in these fields the problem seems to go away. Are empty values treated as a keyword as well?

Thanks,

Henrik
Coordinator
Dec 6, 2006 at 8:05 PM
If you set the ShowMissingParams project property to false, does the problem go away?

Eric
Dec 7, 2006 at 4:51 AM
The "ShowMissingParams" property is already set to "False" for my project.

I will surely try to prepare a dummy dll that I can send across to you so that you can reproduce the issue there.

Thanks,
Sanchit Bahal
Dec 12, 2006 at 12:46 AM
We have ShowMissingParams set to false. Here is a bit from the log file, hope it helps:

Info: Saving file: Help2x.hxc
Info: Saving file: Help2x.HxF
Info: Saving file: MSRSHelp.HxT
Info: Saving file: Help2x_A.HxK
Info: Saving file: Help2x_K.HxK
Info: Saving file: Help2x_F.HxK
Info: Saving file: Help2x_N.HxK
Info: Saving file: Help2x_S.HxK
Info: Saving file: Help2x_B.HxK
Error HXC3031: A group of keywords for a single Help link or KTable exceeds 4,096 bytes.
Error HXC3031: A group of keywords for a single Help link or KTable exceeds 4,096 bytes.
Info: Number of Topics: 4571.
Info: Number of URLs: 4571.
Info: Processing complete.
Info: Number of errors: 2.
Coordinator
Dec 12, 2006 at 2:31 AM
As I stated before I believe this is a help compiler issue. Until someone supplies me with a test case, I can't do anything about it if it is help file builder related.

Eric
Coordinator
Feb 20, 2007 at 9:26 PM
This turned out to be a Sandcastle issue. It will be fixed in the February CTP. See: http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=920978&SiteID=1.
Dec 14, 2010 at 10:03 AM

Hello, 

 

It seems that this issue came back in the latest version of SandCastle and SHFB. Did you find the reason why it this happening? Any advices?

Coordinator
Dec 15, 2010 at 2:42 AM

There is a build component available at http://sandextensions.codeplex.com/ that supposedly fixes the issue. You’ll have to download the code and rebuild it against the latest Sandcastle assemblies though since it hasn’t been updated in a while.

Eric

 

Dec 15, 2010 at 8:09 AM
Edited Dec 15, 2010 at 8:50 AM

Hello Eric, 

I have downloaded the zip and extracted all folders in my SHFB folder. After I ran the build again I got the same error.

I am thinking that the newly added files was not applied (used) since before I extracted them I did not have BuildComponents and PlugIn folders in my SHFB folder and since they are new I do not know how to tell the SHFB to use the files in them. The third folder (PlugIns) I had it before and I assume that it is OK (but not sure if they are used). Can you please let me know how to use those files

Coordinator
Dec 15, 2010 at 8:26 PM

As I mentioned, you'll probably need to rebuild the code against the latest Sandcastle release.  Depending on the state of the project, you may need to update the configuration file used to integrate it with SHFB.  You can find out more about were to put them in this topic and creating configuration files in this topic.  I can't provide support for third-party plug-ins and components so you'll have to contact the developer for support on using them.

Eric

 

Oct 18, 2012 at 11:35 AM

I got this issue again with 1.9.3. 

Is the reason for it indeed the multiple empty params: /// <param name="parameter"></param>. If not, what causes it?

Coordinator
Oct 18, 2012 at 4:09 PM

It appears to be a rare issue and triggered by the content rather than the tools.  As I've mentioned before in this thread, I've yet to have anyone send me a test case so that I can reproduce the problem.  There may be a way to work around it with the tools but until I get something to work with, I can't do anything about it as I can't reproduce the problem.

Eric

 

Oct 18, 2012 at 7:01 PM

I will see if I can get a reproducible scenario, however, the third time I ran the build it went smoothly - without any change in the content. Strange...

Oct 25, 2012 at 1:21 PM

I was able to replicate the issue, unfortunately, I don't think that I will be able to provide you with reproducible project.

On my end the error is observed only when building HELP2 + API and only when using SHFB 1.9.3 with SC 2.6.10621.1. With 1.9.4 the exception does not appear, now I will test with the latest version.