Unknown target platform version '3.0'

Topics: User Forum
Nov 13, 2006 at 10:31 AM
Don't know if this is an MRefBuilder issue or a SHFB issue or both..

Anyway, with the November Sandcastle release and 1.3.2.0 SHFB

- I have .NET 3.0 installed
- I used an old SHFB project if that matters
- FrameworkVersion project property defaults to 3.0 (presumably the highest installed version)

In that case the following happens:

<snip>
Generating reflection information...
C:\GSP\Common\Doc\Help\Working\GenerateRefInfo.bat
MrefBuilder (v2.2.2505.29190)
Copyright ¸ Microsoft 2006
Unknown target platform version '3.0'.
-------------------------------
Removing duplicate topics from reflection.org


If I manually set FrameworkVersion to 2.0.50727 the build succeeds, but then the SDK links .NET 3.0 specific things are missing..
Coordinator
Nov 14, 2006 at 3:57 AM
I think MRefBuilder only targets .NET 1.0, 1.1, and 2.0 right now. You can post a message in the MSDN Documentation forum requesting that support for .NET 3.0 be added.

Eric
Nov 14, 2006 at 11:05 AM
FWIW, there's the link to the thread in the Documentation forum: http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=921738&SiteID=1&mode=1