Unexpected error loading plug-ins

Topics: User Forum
Sep 22, 2010 at 8:11 PM

The first time I hit the "PlugInConfigurations" section in the GUI I get this error:

Unexpected error loading plug-ins: Could not load file or assembly 'SandcastleBuilder.Utils, Version 1.8.0.3, .... etc

I just upgraded to 1.9.1.0 - why would it look for version 1.8.0.3 ?

 

Sep 22, 2010 at 8:26 PM

Actually, I get the same error when I try to build:

SHFB: Error BE0028: Plug-in loading errors:Unable to load plug-in assembly for Additional Content Only:  Assembly: C:\ProgramData\EWSoftware\Sandcastle Help File Builder\Components and Plug-Ins\XML Schema Documenter\XsdDocumentation.PlugIn.plugins  Could not load file or assembly 'SandcastleBuilder.Utils, Version=1.8.0.3, Culture=neutral, PublicKeyToken=71c06e0a0c1c8bf2' or one of its dependencies. The system cannot find the file specified.  Could not load file or assembly 'SandcastleBuilder.Utils, Version=1.8.0.3, Culture=neutral, PublicKeyToken=71c06e0a0c1c8bf2' or one of its dependencies. The system cannot find the file specified.

Coordinator
Sep 23, 2010 at 2:46 AM

You need to upgrade to the latest release of the XML Schema Documenter plug-in which is build against the latest SHFB version.

Eric