F# Syntax

Aug 30, 2010 at 1:59 PM

Is there a way of enabling F# syntax in Sandcastle/SHFB generated help?

I am using the latest versions of all the tools (Sandcastle 2.6.1062.1 with Styles 2.6.10621.1 Patch - Rev 1 and SHFB 1.9.1.0) and it doesn't appear to work. I've tried all three presentation styles and that didn't help. Google brings up some older discussions/release notes which claim that F# syntax is supported.

Any ideas?

Coordinator
Aug 30, 2010 at 4:01 PM

You need to enable F# syntax output by selecting it in the SytnaxFilters project property.  It's definitely supported in the VS2005 style.  I think I added the necessary resource items to the other two styles but don't recall if it's fully supported throughout the transformations.  I think it is but both Hana an Prototype are deprectated and do not support a lot of stuff that's in the VS2005 style.

Eric

 

Sep 8, 2010 at 12:29 PM

Hi Eric,

This worked for me. I didn't know about that option before. Many thanks for your response.

Peter