Unresolved assembly reference

Topics: User Forum
Jul 22, 2010 at 4:21 PM

Hello,

We have used sandcastle for a while and everything is great. But now we are using new libraries.

I added the assembly refrence to my project but for some reason, I get this error from MrefBuilder.

In the output below, I find it weird that it says "0 dependency assemblies" although the assembly is there! I tried MrefBuilder from command line and it worked fine.

Are there problems with building script?

See below output below:

References to use:

Microsoft.SPOT.Hardware

SHFB: Warning BE0062: No XML comments files found. The help file will not contain any member comments.

-------------------------------

Generating shared content files (en-US, English (United States))...

Last step completed in 00:00:00.0060

-------------------------------

Generating API filter for MRefBuilder...

Last step completed in 00:00:00.0010

-------------------------------

Generating reflection information...

[C:\Windows\Microsoft.NET\Framework\v3.5\MSBuild.exe]

GenerateRefInfo:

MrefBuilder (v2.6.10621.1)

Copyright c Microsoft 2006

Info: Loaded 1 assemblies for reflection and 0 dependency assemblies.

MREFBUILDER : error : Unresolved assembly reference: Microsoft.SPOT.Hardware (Microsoft.SPOT.Hardware, Version=4.1.2821.0, Culture=neutral, PublicKeyToken=null) required by MFClassLibrary1

Last step completed in 00:00:00.5340

-------------------------------

Coordinator
Jul 22, 2010 at 7:16 PM

It could be that the version of the assembly used as the reference in the project does not match the one used by MFClassLibrary1.  Rebuilding MFClassLibrary1 with the new version of the library should take care of that.

Eric

 

Jul 22, 2010 at 7:53 PM

Thank you for response.

Actually, it is the correct version, I tried several times... This is what puzzeling me.

I am able to work around this for now. When I copied the referenced assemblies to the same folder as other assemblies, it found them and built documentation successfully.

Sep 21, 2010 at 7:35 AM

Hi,

I am aslo facing the same issue. but I cannot afford to have both the dlls in the same folder. Can you suggest any other workaround?

Rajat

Apr 20, 2011 at 12:37 PM

I know this thread is old, but the problem is cropping up in my project as well.

Has anyone found a fix?

Coordinator
Apr 20, 2011 at 3:06 PM

Are you using the solution or project as the documentation source?  If not, have you tried adding the missing reference to the project's References node?  If the assembly is older but the documentation assembly is expecting a newer version or vice versa, have you tried using the binding redirection plug-in to have it use the assembly you want?

Eric