SHFB and VS 2008

Topics: Developer Forum, Project Management Forum, User Forum
Jan 7, 2008 at 9:19 PM
Where does Sandcastle and SHFB fit in with VS 2008 and .NET 3.5. I need to upgrade to 2008 (long story why I HAVE to) but I am really exited about doing my first TTD project with NUnit and Sandcastle. Are there any considerations? I am quite happy to use 2008 to code 2.0 code as I don't want to jump into 3.5 just yet.
Jan 7, 2008 at 9:58 PM
It should work just fine. Several people are using it with 3.0 and 3.5. The FrameworkVersion project property can be left at 2.0.* as it doesn't have much effect beyond MRefBuilder which only needs to know if its reflecting over a 1.x or 2.x+ assembly. Setting it to 3.x may cause the comments in the list pages for .NET base classes to not appear as I think I need to adjust how its finding the comments for those as 3.0 and 3.5 are a superset of 2.0.