Your version of Sandcastle is out of date. Please download the latest version.

Topics: User Forum
Oct 23, 2006 at 4:28 PM
Hi, I have the Sandcastle September CTP installed. When I run Sandcastle Help File builder, I get this error:

Your version of Sandcastle is out of date. Please download the latest version.

I tried searching for the October 7th Refresh, but I couldn't find it online.

Oct 23, 2006 at 7:09 PM
Download the latest version of Sandcastle from

Oct 16, 2007 at 11:35 AM
Edited Oct 16, 2007 at 11:45 AM
I've downloaded the version of Sandcastle from your link above and I still get the same error as eydelber. It works from the GUI app, but not from the Console app.

This is what I get:

"BUILD FAILED: Your version of Sandcastle is out of date (found '' but expected '2.3.7930.6'). Please download and install the latest version."

Any clues on what is wrong?



I now noticed that this post is from last year, but the link still seams valid, and it says on that page that it is version "2.3.07930.06", just what SHFB wants. But I cannot understand why it doesn't find that version (seams that version might be a default value somewhere?!?)


My version of SHFB is

Ok, it clearly found it in the wrong location, checked the logfile:
"Found Sandcastle in 'C:\Program Files\Visual Studio 2005 SDK\2007.02\VisualStudioIntegration\Tools\Sandcastle\'"

I should be able to get around this now by deleting that folder.
Oct 17, 2007 at 6:20 AM
Actually, this is due to installing the VS SDK as far as I know. When installing it, it modifies the DXROOT environment variable to it's own version of Sandcastle, which is obviously too old as the error message clearly indicates.

Correcting the bad DXROOT environment variable will fix the problem.

@Eric: you might want to consider adding something about this to the FAQ or something ...