Build Fails

Topics: Developer Forum
Nov 14, 2007 at 8:42 PM
I just recently downloaded and installed the latest version of Sandcastle and SFHB and created a project. When I run the build, it fails towards the end when compiling the chm. Below is the section of the output where the error occurs.

-------------------------------
Generating intermediate table of content file...
C:\Docs\Help\Working\GenerateIntermediateTOC.bat
XslTransform (v2.3.8000.26)
Copyright c Microsoft 2005-2006
Info: Applying XSL transformation 'C:\Program Files\Sandcastle\ProductionTransforms\CreateVSToc.xsl'.
Last step completed in 00:00:02.5468
-------------------------------
Generating HTML Help 1.x table of content file...
C:\Docs\Help\Working\Generate1xTOC.bat
XslTransform (v2.3.8000.26)
Copyright c Microsoft 2005-2006
Info: Applying XSL transformation 'C:\Program Files\Sandcastle\ProductionTransforms\TocToChmContents.xsl'.
Last step completed in 00:00:01.9843
Updating table of content with additional content items and determining default topic...
Last step completed in 00:00:00.0156
-------------------------------
Generating HTML Help 1.x index file...
C:\Docs\Help\Working\Generate1xIndex.bat
XslTransform (v2.3.8000.26)
Copyright c Microsoft 2005-2006
Info: Applying XSL transformation 'C:\Program Files\Sandcastle\ProductionTransforms\ReflectionToChmIndex.xsl'.
Last step completed in 00:00:00.5156
-------------------------------
Generating HTML Help 1.x project file...
Last step completed in 00:00:00.0469
-------------------------------
Compiling HTML Help 1.x file...
C:\Docs\Help\Working\Build1xHelpFile.bat
HHC5010: Error: Cannot open "c:\Docs\Help\Working\Output\ZipCodeDownloadWizardsDoc.chm". Compilation stopped.

Could Not Find C:\Docs\Help\Working\Output\ZipCodeDownloadWizardsDoc.chm
Could Not Find C:\Docs\Help\Working\Output\ZipCodeDownloadWizardsDoc.log
Last step completed in 00:00:00.4219


BUILD FAILED: Unexpected error in last build step. See output above for details.

Is there a settings that I'm missing?
Coordinator
Nov 14, 2007 at 9:31 PM
Searching for HHC5010 comes up with two possible problems: The file is either already open or the path contains a folder with period in the name (i.e .NET). The latter doesn't appear to be the case and the help file builder deletes the old one prior to the build so I'm not sure what to suggest. You might check to be sure that the file really doesn't exist and isn't open. You might try changing the name to see if there's something about it that it doesn't like.

Eric
Nov 15, 2007 at 2:26 PM

I looked at the files and the file doesn't exist and there is not periods in the folder name or the entire path. I also tried changing the name to a shorter name and it still came up with the same error.