(Default Namespace) Namespace

Topics: Developer Forum, Project Management Forum, User Forum
Nov 12, 2007 at 4:33 AM

I am using sandcastlebuilderconsole.exe to build class reference.

By default, It add one top-level node named "(Default Namespace) Namespace" with a sub-node "<module> class".

Can you just tell me.. How to eliminate this?

Thank you,

Nov 12, 2007 at 5:16 PM
Add -exclude="" (empty quotes) to the command line which should get it to exclude the default namespace and all types within it such as the <Module> type.

Nov 23, 2007 at 2:31 PM
Hi Eric,

I had tried this. -exclude=""

But it show the ArrayIndexOutBoundsException. Can you please tell me how to resolve this issue.

Nov 23, 2007 at 3:58 PM
If you have a project, use the ApiFilter property to get rid of it. If you are using the command line options alone with no project, use the command line option:


If the type is in a namespace other than the default global namespace, replace the "" with the namespace. By the way, don't just copy and paste that. It looks like you may be missing an "Of" in the name (ArrayIndexOutOfBounds) so verify that you got the name right.