"Open With" in Visual Studio not working

Topics: User Forum
Aug 29, 2007 at 2:51 AM
Edited Aug 29, 2007 at 2:51 AM
Greetings,

First up, LOVE the SHFB, makes my life much easier, so thanks!

Now, I've added our shfb as an item to our solution, and then modified the "Open With" so that it loads the Sandcastle Help File GUI.

Only problem is, it doesn't load the GUI :(

Is this a known issue? I search Issue Tracker, Wiki and Discussion and couldn't see anything...maybe I boy-looked :)

Happy to raise as an issue.
Coordinator
Aug 29, 2007 at 3:13 PM
The info in the help file is a bit outdated. You shouldn't have to modify the tools menu or Open With stuff to get the SHFB projects to open with the GUI from VS. The installer registers the .SHFB extension with the shell to open with the GUI so it should do it automatically from within VS or Explorer. As long as you can see the GUI's sandcastle icon next to the project name, it should just work. If not, perhaps it didn't register correctly. If you do modify the Open With action in VS to open it, I think the key to making it work that way is to make sure you enable the "Set as default" option. You might try deleting the VS Open With entry to see if the shell action takes over and works as expected.

Eric
Aug 30, 2007 at 12:15 AM

EWoodruff wrote:
The info in the help file is a bit outdated. You shouldn't have to modify the tools menu or Open With stuff to get the SHFB projects to open with the GUI from VS. The installer registers the .SHFB extension with the shell to open with the GUI so it should do it automatically from within VS or Explorer. As long as you can see the GUI's sandcastle icon next to the project name, it should just work. If not, perhaps it didn't register correctly. If you do modify the Open With action in VS to open it, I think the key to making it work that way is to make sure you enable the "Set as default" option. You might try deleting the VS Open With entry to see if the shell action takes over and works as expected.

Eric



Thanks Eric, I couldn't remove the existing link (as it was greyed out), tried reinstalling SHFB but alas no luck.

Ended up adding my own link to SHFB GUI, which works just fine.