Strange behaviour with MrefBuilder.exe

Topics: User Forum
Aug 9, 2007 at 11:16 AM
Edited Aug 9, 2007 at 11:21 AM
Hi!
I experienced a problem building the documentation in my first try with the Sandcastle Help File Builder.
This is what I've done: first of all I installed Sandcastle, than I installed this builder and finally the VS2005 SDK in order to use the Help 2.x compiler; I created a new shfb project putting in manually my dlls and xmls (I'v got them in different paths) and finally I tryed to build after having set the correct paths.

Sandcastle Help File Builder GUI, version 1.5.0.1
Creating output and working folders...
Clearing working folder...
Finding tools...
Found Sandcastle in 'C:\Programmi\Sandcastle\'
Found HTML 2.x help compiler in 'C:\Programmi\Visual Studio 2005 SDK\2007.02\VisualStudioIntegration\Archive\HelpIntegration\'
Validating documentation assembly information...
-------------------------------
Creating Sandcastle configuration file...
Last step completed in 00:00:00.0000
-------------------------------
Generating shared content files (en-US)...
Last step completed in 00:00:00.0156
-------------------------------
Generating reflection information...
C:\...path...\doc\Working\GenerateRefInfo.bat
MrefBuilder (v2.2.64000.4)
Copyright ¸ Microsoft 2006
Error: The type 'Microsoft.Ddue.Tools.Reflection.AssemblyResolver' was not found in the component assembly 'C:\Programmi\Visual Studio 2005 SDK\2007.02\VisualStudioIntegration\Tools\Sandcastle\\ProductionTools\MRefBuilder.exe'.
Last step completed in 00:00:00.6875


BUILD FAILED: Unexpected error in last build step. See output above for details.

I really don't know why it's looking for the exe in the VS SDK folder (I set the right Sandcastle folder) and I saw that strange double slash in '.....\Sandcastle\\ProductionTools\MRefBuilder.exe'.
Aug 9, 2007 at 1:10 PM
Ops!
I'm sorry, I just found the answer in another post...

http://www.codeplex.com/SHFB/Thread/View.aspx?ThreadId=13179