This project has moved and is read-only. For the latest updates, please go here.

Sandcastle June CTP buildassembler oddity

Topics: Developer Forum, User Forum
Jul 9, 2007 at 7:20 PM
Is anyone else seeing this? I've tried this on xp pro x32, xp pro x64, and vista x64. It seems buildassembler is not just reading the reflection xml files but also writing them. I get errors about the xml files not validating. when I check the files at the line numbers given, I see odd things like names obviously wrong. LIke t his:

Manually changing these sometimes allows it to work. Most of the time buildassembler simply crashes with no stack trace output. This is with June CTP refresh. Anyone got a link to an older build of sandcastle that actually works?
Jul 9, 2007 at 8:53 PM
BuildAssembler never writes to reflection.xml. One of my components reads from it but doesn't alter it. Have you tried uninstalling and reinstalling everything? Also, if you've got the Visual Studio SDK installed be sure that DXROOT is pointing to the June CTP and not its version.

Jul 9, 2007 at 10:39 PM
Nice point about the VS SDK however DXROOT is pointing to c:\program files (x86)\Sandcastle. Would network problems cause an issue with the MSDN Url Resolver? could that be the problem?
Jul 9, 2007 at 11:36 PM
It can but in those cases you usually get an error referring to the MSDN web service, the proxy, or an invalid response from the web service. You'll also see references to the web service related methods in the stack trace.