This project has moved and is read-only. For the latest updates, please go here.

SdkLinking for Windows Presentation Foundation

Topics: User Forum
Jul 3, 2007 at 6:09 PM
I'm currently generating APIs for our Windows Presentation Foundation (WPF) assemblies, and I notice that even with the FrameworkVersion set to 3.0, it still doesn't link any of the specific WPF objects, properties, or members (i.e., UIElement, Visual, DependencyObject, DispatcherObject, FrameworkElement, etc). I have the SdkLinkType set to MSDN.

I'm assuming this would be a Sand Castle issue, and not a Help File Builder issue, but wasn't 100% sure. Does anyone know if Sand Castle understands the WPF assemblies (PresentationCore and PresentationFramework)?
Jul 3, 2007 at 8:31 PM
It could be a Sandcastle issue. I haven't gotten around to installing the .NET 3.0 stuff yet. You can try a command line build using the example script in the Example\Sandcastle folder under the Sandcastle installation folder. You can modify it and the test.cs file to include some of the references in question to see if you get the same result. If you do, ask in the MSDN Documentation forum to see if it's a known issue or if there is something that needs to be done in order to get it to recognize them.

Jul 11, 2007 at 3:01 AM
Just a guess. The WPF assemblies probably don't have any reflection information present in the Sandcastle data folder. If this is the cause, you can fix it by manually running MRefBuilder on the WPF assemblies and copying the resulting files to the Data\Reflection folder under the main Sandcastle installation folder. You'll find all the reflection data for the .NET 2.0 assemblies there already. To run it manually, pass it the name of the assembly and the output filename:

MRefBuilder The.WPF.Assembly.dll /out:The.WPF.Assembly.xml

Jul 11, 2007 at 8:05 PM
This is just a connection link to this discussion on the MSDN Developer Documentation and Help System Forums. As it appears to be an issue with SandCastle and not the Help File Builder.